Bug 620635 - antlr3 needs to be rebuilt against python 2.7 in F14 and devel
antlr3 needs to be rebuilt against python 2.7 in F14 and devel
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: antlr3 (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Milos Jakubicek
Fedora Extras Quality Assurance
AcceptedBlocker
:
: 623269 (view as bug list)
Depends On:
Blocks: F14Blocker/F14FinalBlocker Python27Rebuild
  Show dependency treegraph
 
Reported: 2010-08-03 01:30 EDT by Orcan Ogetbil
Modified: 2010-10-19 05:10 EDT (History)
8 users (show)

See Also:
Fixed In Version: antlr3-3.2-11.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-19 05:10:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orcan Ogetbil 2010-08-03 01:30:37 EDT
The package needs to be rebuilt against python 2.7 in both F14 and devel.

Information on the new "dist-git" system can be seen here:
  http://fedoraproject.org/wiki/Using_Fedora_GIT

Information on common difficulties with Python 2.7 rebuilds can be seen here:
  https://fedoraproject.org/wiki/Features/Python_2.7

Once it's been successfully rebuilt for F14, an update needs to be filed to get the rebuild into F14:
  https://admin.fedoraproject.org/updates/new/

Please add this bug to the update, to make it easy to track what's been done, and what's left to do.

Thanks!
Comment 1 Orcan Ogetbil 2010-08-03 01:35:23 EDT
antlr3 has a build dependency on maven2-plugin-antlr, which doesn't exist on Fedora anymore:
   http://fedoraproject.org/wiki/MavenUpdatePlugins

The build fails with
   [INFO] Unable to find resource 'org.apache.maven.plugins:maven-antlr-plugin:pom:DUMMY_VER' in repository __jpp_repo__ (file:///usr/share/maven2/repository)

I removed the maven-plugin-antlr entry from the .pom file and tried. This time I get a
   cannot find symbol
   symbol  : variable ANTLRParser
   location: class org.antlr.tool.Grammar

Apparently, the missing library is really required to build the package. Can we patch those parts out to remove the dependency?
Comment 2 Orcan Ogetbil 2010-08-07 12:31:44 EDT
Hello. Colin, how is the progress on this bug? It will probably get removed from F-14 if you don't act soon.
Comment 3 Milos Jakubicek 2010-08-07 17:24:49 EDT
Orcan, I'll look into this when I come back from vacation (in 2 weeks).
Comment 4 Dave Malcolm 2010-08-11 20:43:12 EDT
*** Bug 623269 has been marked as a duplicate of this bug. ***
Comment 5 Orcan Ogetbil 2010-08-30 13:37:12 EDT
Hello. Any progress? Milos?
Comment 6 Milos Jakubicek 2010-08-31 01:29:46 EDT
The antlr(2)-maven-plugin is no longer part of maven2, I'm going to submit it separately (even already have a reviewer:), just a bit stuck now with my $DAYJOB, but this definitely is going to be solved:)
Comment 7 Bart Vanbrabant 2010-09-15 11:01:53 EDT
The antlr python runtime is outdated but there is not updated version available. I install the python runtime, but I use an older antlr jar to generate the recognizer.

I suggest removing the python runtime from the package because you have to download non-packaged version anyway to be able to use antlr3 on Fedora.
Comment 8 Bill Nottingham 2010-10-04 16:41:21 EDT
Milos - we're running pretty late with F-14 here. I'm not seeing the antlr-maven-plugin submission?
Comment 9 Adam Williamson 2010-10-08 12:55:49 EDT
This was discussed and accepted as a blocker at the 2010-10-08 review meeting, criterion "There must be no file conflicts (cases where the files in some packages conflict but the packages have explicit Conflicts: tags are acceptable) or unresolved package dependencies during a media-based (CD/DVD) install". Please implement a solution to the dependency issue ASAP, Bart's suggestion to remove the package would be fine for the purpose of the release...
Comment 10 Orcan Ogetbil 2010-10-08 14:10:58 EDT
I wish the issue was as simple as "don't build the python bindings". No. This packages FTBFS, even without the python bindings.

The missing build dependency is _really_ needed to build the core of this  package.

Milos, what is going on?
Comment 11 John Poelstra 2010-10-11 13:42:53 EDT
We need confirmation from the maintainer that this is going to get fixed and when.  Please let us know here.

Thank you,
John
Comment 12 Tom "spot" Callaway 2010-10-13 09:01:27 EDT
I think I've got this working locally now. Updates as soon as I'm sure.
Comment 13 Fedora Update System 2010-10-13 15:46:04 EDT
antlr3-3.2-11.fc14,antlr-maven-plugin-2.1-3.20101012svn12849.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/antlr3-3.2-11.fc14,antlr-maven-plugin-2.1-3.20101012svn12849.fc14
Comment 14 Fedora Update System 2010-10-13 17:21:11 EDT
antlr3-3.2-11.fc14, antlr-maven-plugin-2.1-3.20101012svn12849.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update antlr3 antlr-maven-plugin'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/antlr3-3.2-11.fc14,antlr-maven-plugin-2.1-3.20101012svn12849.fc14
Comment 15 Fedora Update System 2010-10-19 05:10:36 EDT
antlr3-3.2-11.fc14, antlr-maven-plugin-2.1-3.20101012svn12849.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.