Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 620653 - [abrt] crash in fedora-packager-0.4.2.3-1.fc13: <string>:1:connect:error: [Errno 111] Connection refused
[abrt] crash in fedora-packager-0.4.2.3-1.fc13: <string>:1:connect:error: [Er...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: fedora-packager (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
abrt_hash:a8b6448c
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-03 04:15 EDT by Enrico Scholz
Modified: 2013-01-10 01:07 EST (History)
2 users (show)

See Also:
Fixed In Version: fedora-packager-0.5.1.2-2.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-17 01:36:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.72 KB, text/plain)
2010-08-03 04:15 EDT, Enrico Scholz
no flags Details

  None (edit)
Description Enrico Scholz 2010-08-03 04:15:19 EDT
abrt 1.1.1 detected a crash.

architecture: x86_64
cmdline: /usr/bin/python /usr/bin/fedpkg build
component: fedora-packager
executable: /usr/bin/fedpkg
kernel: 2.6.33.6-147.fc13.x86_64
package: fedora-packager-0.4.2.3-1.fc13
reason: <string>:1:connect:error: [Errno 111] Connection refused
release: Fedora release 13 (Goddard)

backtrace
-----
<string>:1:connect:error: [Errno 111] Connection refused

Traceback (most recent call last):
  File "/usr/bin/fedpkg", line 903, in <module>
    args.command(args)
  File "/usr/bin/fedpkg", line 297, in build
    mymodule.init_koji(args.user, kojiconfig)
  File "/usr/lib/python2.6/site-packages/pyfedpkg/__init__.py", line 980, in init_koji
    defaults['serverca'])
  File "/usr/lib/python2.6/site-packages/koji/__init__.py", line 1628, in ssl_login
    sinfo = self.callMethod('sslLogin', proxyuser)
  File "/usr/lib/python2.6/site-packages/koji/__init__.py", line 1673, in callMethod
    return self._callMethod(name, args, opts)
  File "/usr/lib/python2.6/site-packages/koji/__init__.py", line 1698, in _callMethod
    return proxy.__getattr__(name)(*args)
  File "/usr/lib64/python2.6/xmlrpclib.py", line 1199, in __call__
    return self.__send(self.__name, args)
  File "/usr/lib64/python2.6/xmlrpclib.py", line 1489, in __request
    verbose=self.__verbose
  File "/usr/lib64/python2.6/xmlrpclib.py", line 1235, in request
    self.send_content(h, request_body)
  File "/usr/lib64/python2.6/xmlrpclib.py", line 1349, in send_content
    connection.endheaders()
  File "/usr/lib64/python2.6/httplib.py", line 892, in endheaders
    self._send_output()
  File "/usr/lib64/python2.6/httplib.py", line 764, in _send_output
    self.send(msg)
  File "/usr/lib64/python2.6/httplib.py", line 723, in send
    self.connect()
  File "/usr/lib/python2.6/site-packages/koji/ssl/SSLCommon.py", line 108, in connect
    self.sock.connect((self.host, self.port))
  File "<string>", line 1, in connect
error: [Errno 111] Connection refused

Local variables in innermost frame:
self: <socket._socketobject object at 0x113c910>
args: (('koji.stg.fedoraproject.org', 443),)

How to reproduce
-----
1. use fedpkg behind a proxy
2. set correct $http_proxy + $https_proxy env
3. try to connect
Comment 1 Enrico Scholz 2010-08-03 04:15:21 EDT
Created attachment 436206 [details]
File: backtrace
Comment 2 Dennis Gilmore 2010-08-03 08:41:53 EDT
You need to use the latest fedora-packager either from updates-testing or koji.
Comment 3 Enrico Scholz 2010-08-04 03:53:33 EDT
still with 0.5.1
Comment 4 Jesse Keating 2010-08-06 15:20:43 EDT
Hrm, two things going on.

1) we should trap that error instead of backtracing.

2) we should be able to get the proxy to work.  

Does regular /usr/bin/koji work when you have proxy env variables set?
Comment 5 Enrico Scholz 2010-08-11 08:36:07 EDT
In old buildsystem, I set

| BUILD_CLIENT  = ${HOME}/bin/tkoji

in ~/.cvspkgsrc where this tkoji program is a wrapper which calls 'koji' through transconnect[1].

Where can I configure the koji command in fedpkg?  Wrapping whole 'fedpkg' through transconnect is probably a bad idea because the other functionality (ssh, git) works fine with proxies.


[1] http://transconnect.sourceforge.net
Comment 6 Jesse Keating 2010-08-12 03:04:28 EDT
Well, we now should catch the error and not traceback, however for proxy stuff I think that's a second bug that should be opened.

With fedpkg you can't really override the /usr/bin/koji call because we don't call /usr/bin/koji, we deal with koji through it's python API.  It seems to me that the koji api should handle proxies in a way that would work for you.  Can you file a bug against koji and work with their upstream on that?  This bug will get handled by bodhi when an update gets pushed to catch this error instead of tracing back.
Comment 7 Fedora Update System 2010-08-12 15:53:26 EDT
python-kitchen-0.2-0.1.a2.el5,fedora-packager-0.5.1.2-1.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/python-kitchen-0.2-0.1.a2.el5,fedora-packager-0.5.1.2-1.el5
Comment 8 Fedora Update System 2010-08-12 15:57:03 EDT
fedora-packager-0.5.1.2-1.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/fedora-packager-0.5.1.2-1.fc14
Comment 9 Fedora Update System 2010-08-12 16:01:31 EDT
fedora-packager-0.5.1.2-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/fedora-packager-0.5.1.2-1.fc13
Comment 10 Fedora Update System 2010-08-12 16:07:26 EDT
fedora-packager-0.5.1.2-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/fedora-packager-0.5.1.2-1.fc12
Comment 11 Fedora Update System 2010-08-13 17:06:23 EDT
fedora-packager-0.5.1.2-2.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update fedora-packager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/fedora-packager-0.5.1.2-2.fc13
Comment 12 Fedora Update System 2010-08-13 18:39:01 EDT
fedora-packager-0.5.1.2-2.el5, python-kitchen-0.2-0.1.a2.el5 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update fedora-packager python-kitchen'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/python-kitchen-0.2-0.1.a2.el5,fedora-packager-0.5.1.2-2.el5
Comment 13 Fedora Update System 2010-08-17 01:35:57 EDT
fedora-packager-0.5.1.2-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2010-08-24 17:09:11 EDT
fedora-packager-0.5.1.2-2.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2010-08-24 19:03:36 EDT
fedora-packager-0.5.1.2-2.el5, python-kitchen-0.2-0.1.a2.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2010-08-24 21:19:21 EDT
fedora-packager-0.5.1.2-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.