Bug 62067 - Unable to resume from suspend after starting X (Radeon)
Unable to resume from suspend after starting X (Radeon)
Status: CLOSED DUPLICATE of bug 65384
Product: Red Hat Public Beta
Classification: Retired
Component: XFree86 (Show other bugs)
skipjack-beta1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks: 61901 67218
  Show dependency treegraph
 
Reported: 2002-03-27 01:57 EST by Robert Spier
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-21 17:05:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Spier 2002-03-27 01:57:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9+) Gecko/20020317

Description of problem:
After starting X with the accelerated radeon driver, my IBM ThinkPad X22 is
unable to resume from a APM suspend (and is completely hung/frozen)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. boot notebook
2. start X (just the X Server itself will do)
3. suspend via (any of) Fn-F4, apm -s, closing cover
4. resume, either by opening cover or hitting 'Fn'
	

Actual Results:  Machine begins to resume (half moon light goes from solid to
blinking) and hangs there for ever.  Must force a power off by holding down
power button.

Expected Results:  The machine should have resumed.

Additional info:

- I'm 99% positive this is a problem with either the radeon drm kernel driver,
or the agpgart kernel driver.  If I use the 'vesa' XFree86 driver, everything is
fine, albeit slowly.
- As long as I don't start X (i.e. stay in console mode) suspend and resume work
fine.  If I start X, exit X, and unload the kernel modules, it will show the
symptoms.
- Machine is brand new.
- Web sites found with google imply that this works for other people with the
same or very similar machines.  (Although not with SkipJack - although other
people are using both 2.4.18 and XFree86 4.2, although not necessarily together.)
- Machine is a P3 - 800Mhz Mobile, Radeon Mobility M6 LY chip, 128 MB Ram. 
Everything else is working fine.
- I've tried disabling apmd, no change.
- I've tried a 2.4.17 kernel, 2.4.18 stock kernel, 2.4.19-pre3-ac6 kernel, and
no change.
- I thought about ACPI, but the Linux userspace support doesn't seem ready yet.
- I'd love to know how to debug this problem.  It's happening at a very
inopportune time.  The only thing I can think of is something with a serial console.
Comment 1 Mike A. Harris 2002-03-28 01:43:58 EST
Switch to a VC fitrst prior to using apm suspend.  Does this work around the
problem?
Comment 2 Robert Spier 2002-03-28 02:23:19 EST
No.  
That was one of the first things I tried.

I can start X.  
Exit X.
rmmod the agpgart and radeon modules.
Suspend.
And then the machine is unable to resume properly.
(So it seems that one of those modules is stepping on something it shouldn't.)
Comment 3 Mike A. Harris 2002-03-28 03:34:55 EST
Ok.  I've Cc'd Arjan, since this looks like it is a kernel problem.
I strongly recommend also checking out IBM's website and ensuring that
your BIOS is updated to whatever their latest BIOS is.  Frequently
APM related problems are fixed with a BIOS update.
Comment 4 Robert Spier 2002-03-28 08:12:36 EST
BIOS and Embedded Controller are up to date (and I'm still seeing the problem.)
 I did an upgrade two days ago.  
BIOS information for my notebook:
   http://www.pc.ibm.com/qtechinfo/MIGR-4LXTHS.html
Current Versions:
  (latest versions on website, and versions on my laptop, as of today)
   BIOS 1.21 (Released 6 Mar 2002)
   Embedded Controller 1.17 (Released 5 Mar 2002)
Comment 5 Robert Spier 2002-04-21 00:42:30 EDT
I've upgraded the kernel, apm, and XFree86 to the rpm's from skipjack-beta2, and
the problem still exists.
(Arjan- is there anything I can do to help get you more information on this, or
anything you can point me at to help debug this?)
Comment 6 Robert Spier 2002-06-21 17:05:55 EDT
Related to/Duplicate of bug 65384
Comment 7 Mike A. Harris 2002-07-20 09:26:28 EDT

*** This bug has been marked as a duplicate of 65384 ***

Note You need to log in before you can comment on or make changes to this bug.