Bug 620699 - s390x mkinitrd lacks requirement on dmraid
Summary: s390x mkinitrd lacks requirement on dmraid
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: mkinitrd
Version: 5.7
Hardware: s390x
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Brian Lane
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks: 726828
TreeView+ depends on / blocked
 
Reported: 2010-08-03 09:50 UTC by Philip Rowlands
Modified: 2012-02-21 05:33 UTC (History)
4 users (show)

Fixed In Version: mkinitrd-5.1.19.6-73
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-02-21 05:33:50 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0157 normal SHIPPED_LIVE mkinitrd bug fix update 2012-02-20 14:54:17 UTC

Description Philip Rowlands 2010-08-03 09:50:04 UTC
# mkinitrd /tmp/initrd.img 2.6.18-94.el5
WARNING: using /tmp for temporary files
cp: cannot stat `/sbin/dmraid.static': No such file or directory


To reproduce, run mkinitrd without dmraid package installed on s390x.

I'm unsure of the history here, but it appears mkinitrd's dmraid support initially excluded the s390x arch, but that appears to have changed in dmraid in 2006:

* Thu Aug 17 2006 Peter Jones <pjones@redhat.com> - 1.0.0.rc11-FC6.3
- No more excludearch for s390/s390x


Suggested fix is to remove the %ifnarch around Requires: dmraid in mkinitrd.spec. People more familiar with mkinitrd/dmraid history might think of other places in the code where this arch-specific behaviour applies.

Comment 1 Philip Rowlands 2010-09-22 12:54:28 UTC
Ping?

Comment 2 RHEL Program Management 2011-08-05 12:30:01 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 4 Jan Stodola 2012-01-02 11:51:21 UTC
mkinitrd from RHEL-5.8 Snapshot 2 depends on dmraid:

[root@rtt7 ~]# rpm -q mkinitrd
mkinitrd-5.1.19.6-75.el5
[root@rtt7 ~]# rpm -q --requires mkinitrd | grep dmraid
dmraid
[root@rtt7 ~]#

There is no error message when building initramdisk on a system with minimal package set.


Moving to VERIFIED.

Comment 5 errata-xmlrpc 2012-02-21 05:33:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0157.html


Note You need to log in before you can comment on or make changes to this bug.