Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 620707 - Enable Web Albums export extension
Enable Web Albums export extension
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gthumb (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Christian Krause
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-03 06:07 EDT by Mark Wielaard
Modified: 2010-09-01 01:54 EDT (History)
2 users (show)

See Also:
Fixed In Version: gthumb-2.11.90-3.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-31 23:23:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Wielaard 2010-08-03 06:07:34 EDT
Description of problem:

Since gthumb 2.11.5 there is a new rewritten Web Albums export extension. This is however not enabled in the fedora package because it requires bison and flex during the build.

Version-Release number of selected component (if applicable):

gthumb-2.11.5-1.fc13.x86_64

How reproducible:

Always.

Steps to Reproduce:
1. Look under export/extensions.
  
Actual results:

No Web Album...

Expected results:

Ability to export as static web album.

Additional info:

Requires the following patch to the gthumb.spec file:

diff --git a/gthumb.spec b/gthumb.spec
index bdb3033..c0aa2ed 100644
--- a/gthumb.spec
+++ b/gthumb.spec
@@ -44,6 +44,9 @@ BuildRequires: gnome-common
 
 BuildRequires: rarian-compat
 
+# For Web albums
+BuildRequires: bison flex
+
 Requires(post): desktop-file-utils >= %{desktop_file_utils_version}
 Requires(postun): desktop-file-utils >= %{desktop_file_utils_version}
 Requires(pre): GConf2 >= %{gconf_version}
Comment 1 Christian Krause 2010-08-22 09:28:57 EDT
Fixed in rawhide, an update for F14 and F13 will be available soon.
Comment 2 Fedora Update System 2010-08-22 15:22:43 EDT
gthumb-2.11.90-3.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/gthumb-2.11.90-3.fc14
Comment 3 Fedora Update System 2010-08-22 15:24:02 EDT
gthumb-2.11.90-3.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/gthumb-2.11.90-3.fc13
Comment 4 Fedora Update System 2010-08-23 15:02:54 EDT
gthumb-2.11.90-3.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gthumb'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/gthumb-2.11.90-3.fc14
Comment 5 Fedora Update System 2010-08-31 23:23:34 EDT
gthumb-2.11.90-3.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2010-09-01 01:54:26 EDT
gthumb-2.11.90-3.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.