Bug 62072 - No XFS filesystem in the kernel
No XFS filesystem in the kernel
Status: CLOSED DEFERRED
Product: Red Hat Public Beta
Classification: Retired
Component: kernel (Show other bugs)
skipjack-beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-27 03:10 EST by Simon Matter
Modified: 2007-04-18 12:41 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-17 02:13:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Simon Matter 2002-03-27 03:10:15 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [de] (X11; U; Linux 2.2.19-6.2.16 i686)

Description of problem:
When I try to install or upgrade a server with skipjack-beta1, there is still no
support for the SGI XFS available. No support in the installer and no support in
the kernel.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start installation of skipjack-beta1
2. when partitioning, try to choose XFS as filesystem type
3.
	

Actual Results:  I couldn't perform the step since XFS does not exist.

Expected Results:  I can choose XFS from the filesystem pulldown menu like I can
choose ext2 or ext3.

Additional info:

Imagine what happens if you want to upgrade an XFS enabled RedHat 7.2 system.

XFS should be an option. It's important for enterprise class servers. While ext3
is really nice, XFS has advantages that let many corporate customers of RedHat
choose XFS over ext3. I'd be very happy to see RedHat gives us real choice for
filesystem on enterprise class servers.
Comment 1 Arjan van de Ven 2002-03-27 03:56:48 EST
"Imagine what happens if you want to upgrade an XFS enabled RedHat 7.2 system."

"XFS enabled Red Hat Linux 7.2 systems" don't exist.

I wonder which features of XFS you are interested in that aren't provided by
ext3 (and are without unofficial ABI's etc)
Comment 2 Dan Yocum 2002-03-27 09:09:46 EST
Arjan,

One "feature" of XFS is that we (Sloan Digital Sky Survey) already have it
installed on about 20TB of disk systems running Red Hat, and converting those
disks to ext3 would be cost/time prohibitive.  I know the D-Zero experiment here
at Fermilab have several TB of XFS disks on Red Hat systems, too.

In other words, XFS is pretty much entrenched here, so, yes, we'd like to see it
in the official RH distro, too.  

As far as support goes, why not have a level 3 contract with SGI on a per
incident basis...

Cheers,
Dan
yocum@fnal.gov
Comment 3 Arjan van de Ven 2002-03-27 09:22:40 EST
Paying someone else money for backward compatibility with something we never
shipped (Red Hat Linux never supported XFS, SGI Linux does but that's a
different distro) doesn't sound like a good business plan to me.
Comment 4 Simon Matter 2002-03-27 12:57:30 EST
I'm not starting a flamewar here... I'm just asking you to improve RedHat Linux
again.

Many people started using XFS on RedHat systems. In my company for example we
started using XFS before ext3 was available on RedHat. One of the reasons was to
get quick crash recovery, waiting hours for fsck was a horror. We're now using
both XFS and ext3.

Some reasons why we will continue using XFS beside ext3:
o journaled quota info (no quotachk)
o native growfs support (works while FS is mounted )
o standard *nix dump/restore tools that will handle EA/ACLs/quota
o scalability to extremely large filesystems as Linux capabilities grow
o DMAPI support (few people need this though)
o Works and integrates well with software RAID, LVM, NFS, LILO, GRUB
o newest Samba 2.2.3a allows Windows file sharing with NT-like ACLs on XFS
o system calls for extended attributes are now in Linus's kernel ( not
"unofficial ABI's" ).

We don't want to switch to another distribution.
Comment 5 Dana Canfield 2002-04-09 18:23:55 EDT
Hate to annoy people, but since this hasn't been closed, I'm assuming there's a
chance of convincing someone at redhat that this is a good idea, so I just
wanted to add my own vote for XFS as well.  As mentioned before, XFS has several
great features that just aren't available with the other fs types (for us, the
ACL's and samba integration are key).

You needn't even offer it as an "install" feature... just including the patch in
kernel RPM's and making sure that XFS partitions aren't broken by upgrades would
be sufficient to make me happy.  That way, only people who really know what they
are doing can get XFS enabled.  (And at least for my uses, ext3 is fine for
boot/root partitions.)

Thanks
Comment 6 Simon Matter 2002-04-10 07:09:46 EDT
I agree with the previous poster.
Even if there is no "installation support", we're happy to get an official RH
kernel with XFS and the xfs tools like we get LVM or ReiserFS.

Distributions supporting XFS beside ext3 are (AFAIK):
o Mandrake 8.2         http://www.linux-mandrake.com/en/82.php3
o SuSE 8.0               http://www.urz.uni-heidelberg.de/Linux/suse80-ank.shtml
o Gentoo 1.1a           http://www.gentoo.org/doc/build.html
o Slackware current   http://www.slackware.com/
o Debian Testing

As much as I like the new alternatives method for packages in Skipjack-beta1,
I'd like alternatives for journaling filesystems.
Comment 7 Need Real Name 2002-04-15 12:24:01 EDT
From what I understand the ACL kernel API was standardized in the 2.4.18 kernel.  

The team at http://acl.bestbits.at/ that support ext2/ext3 patches for ACLs and
the XFS support team have merged their user tools for working with ACLs.

The JFS team has stated that adding ACL support is a top priority now that there
is a standard API in the kernel.  I imagine they too will use the above userland
tools.

End-user code such as Samba 2.2.3a support this interface.

In other words, I would say the ACLs in Linux have gone from experimental to
standardized.

As a user, I want to use this new standard Linux feature.

I would like to see official Redhat support of ACLs.  I don't really care if it is:

   XFS
   ext2/ext3 with the http://acl.bestbits.at/ extensions
   A possible future JFS.

One nice thing about XFS is that it does come with xfsdump and xfsrestore.  

For the acl.bestbits solution, there is enhanced version of tar: star.
Comment 8 Arjan van de Ven 2002-04-15 12:25:46 EDT
sorry but 2.4 doesn't have the ACL interface yet and in 2.5 it's still somewhat
immature (eg not set in stone)
Comment 9 Simon Matter 2002-04-17 02:12:54 EDT
As a RedHat user and responsible for getting RedHat in into several companies in
Switzerland and Germany in the last 5 years, I'm not interested in code details
too much but I'm interested to get the best features in a usable package. XFS
has and will be widely used in the corporate world and I'm not going to tell
customers we have to change it. One year ago it was easy to explain the kernel
patching ceremonie because no distribution supported XFS out of the box but
customers wanted it anyway. Now, most major distributions - beside RedHat -
support XFS out of the box. Is it difficult to realize that RedHat without XFS
becomes a pain for me in the year 2002?

It's obvious that people like me helped RedHat to succeed with their new
business plan, which is hunting Unix and replacing it with Linux. People,
starting in hidden places replacing NT with Linux and implementing Internet
services based on Linux, _this_ is how Managments were convinced to go the Linux
way, nothing else. Now how can we convince RedHat?

Now, if we really have to talk about EA/ACL details, let me quote here what an
ACL developer has to say concerning your statement above:
It's hypocritical to claim that these EA/ACL interfaces can't be used because
the ABI _might_ change (which is extremely unlikely - neither the XFS nor the
ext2/3 projects have any plans to change the EA format for ACLs; the format also
has a version field which can be used to support backward compatibility _if_
that should ever become necessary; and userspace uses the libacl API which hides
this anyway!), while most of the distributors, including Redhat, use a
quotactl(2) interface with an ABI which _does_ differ to that in the standard
kernels from Linus/Marcelo.

Is there a chance to convince RedHat to include XFS if the XFS developers
provided a clean XFS patch for the most recent skipjack kernel?
Comment 10 Arjan van de Ven 2002-04-17 03:51:34 EDT
This used to be a sane bug. Now it seems (via xfs ml etc) to be some sort of
propaganda campain; I'm not interested in being the target of PR campaigns.

Note You need to log in before you can comment on or make changes to this bug.