Bug 62075 - ntpd should be started (or restarted) after pcmcia ethernet interface is brought up
ntpd should be started (or restarted) after pcmcia ethernet interface is brou...
Status: CLOSED NOTABUG
Product: Red Hat Public Beta
Classification: Retired
Component: ntp (Show other bugs)
skipjack-beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-27 03:32 EST by Bill Crawford
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-10 14:46:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of ntpdc (729 bytes, text/plain)
2002-04-02 14:30 EST, Bill Crawford
no flags Details

  None (edit)
Description Bill Crawford 2002-03-27 03:32:00 EST
Description of Problem:
Although the PCMCIA ethernet interface is coming up ok after the grep bugfix
(how the **** did you guys track that one down?) I still have an issue with
ntp.  I have dhcpd configured on another machine to serve DHCP requests from the
laptop, and I'm setting ntp-servers; the laptop has been picking up the settings
OK, but doesn't appear to [re]start the ntp service after the i/f is
configured.  Not that it's critical on a laptop, of course.  Manually restarting
ntp causes it to sync properly.
Comment 1 Trond Eivind Glomsrxd 2002-03-27 11:41:16 EST
Changing from hotplug to ntp.
Comment 2 Harald Hoyer 2002-04-02 10:41:12 EST
after the interface if up can you:

$ ntpdc localhost
> peers

please? Maybe you have to wait until ntpd retries to connect to your time server?
Comment 3 Bill Crawford 2002-04-02 14:30:00 EST
Created attachment 51904 [details]
output of ntpdc
Comment 4 Bill Crawford 2002-04-02 14:40:05 EST
It may or may not eventually pick up the servers.  Thing is, though, with a
laptop, I may not have it switched on long enough for it to actually synchronize
this way, whereas if it was synced when I booted up or when the interface was
brought up it would be synchronized ... and I wouldn't get the [FAILED] message
at boot time if pcmcia was started before ntp.

I'm particularly concerned because I'm getting the ntp settings from DHCP, so I
really need the service to be restarted if these details change anyway. 
Otherwise if I change the time server(s), it'll be using the settings from last
time I booted, too.  If I wanted to use the laptop on two (or more) different
networks, and rely on DHCP to get all the information for me, I'd be stuck (and
I do plan to do this).

It would also be nice if ntp could be stopped if DHCP returns no time servers,
or perhaps there could be a fallback setting?

I wasn't able to find anywhere to specify services to [cond]restart or reload
after an interface was hotplugged, can you give me a pointer?
Comment 5 Harald Hoyer 2002-04-03 03:09:12 EST
modify /etc/pcmcia/network, and restart any services there, you need
Comment 6 Jay Turner 2002-04-10 14:46:26 EDT
So, seems that we are just going to leave this in the hands of the user. 
Closing out.

Note You need to log in before you can comment on or make changes to this bug.