Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 620797 - systemd-gtk does not start
systemd-gtk does not start
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
14
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-03 10:05 EDT by Andreas Bierfert
Modified: 2010-08-06 07:26 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-06 07:26:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andreas Bierfert 2010-08-03 10:05:15 EDT
/usr/bin/systemadm 
Gtk-Message: Failed to load module "atk-bridge": libatk-bridge.so: cannot open shared object file: No such file or directory

(systemadm:2996): Bonobo-WARNING **: Bonobo must be initialized before use

(systemadm:2996): GLib-GObject-CRITICAL **: g_object_ref_sink: assertion `G_IS_OBJECT (object)' failed

First one probably is a missing require on at-spi2-atk-0.3.5-1.fc14.x86_64...
Comment 1 Michal Schmidt 2010-08-04 09:58:33 EDT
(In reply to comment #0)
> /usr/bin/systemadm 
> Gtk-Message: Failed to load module "atk-bridge": libatk-bridge.so: cannot open
> shared object file: No such file or directory
> 
> (systemadm:2996): Bonobo-WARNING **: Bonobo must be initialized before use

I'm getting these messages too. But they do not prevent systemadm from starting.

> (systemadm:2996): GLib-GObject-CRITICAL **: g_object_ref_sink: assertion
> `G_IS_OBJECT (object)' failed

I'm not seeing this one.

Are you sure you have booted the system with systemd and not with upstart?

What version do you have? rpm -q systemd-gtk dbus
Comment 2 Andreas Bierfert 2010-08-04 15:47:53 EDT
dbus-1.3.2-0.0.885483.fc14.x86_64
systemd-gtk-5-2.fc14.x86_64

It does not matter uf U start with upstart or systemd.

Not related to this error but systemd fails to start vital services like messagebus and of course stuff which depends on it fails to start after that like avahi, NetworkManager etc. This is on an upgrade from f13
Comment 3 Andreas Bierfert 2010-08-05 14:45:20 EDT
Most issues are fixed after installing latest dbus. However, still seeing:

 ** (systemadm:4991): WARNING **: AT-SPI: Accessibility bus not found - Using session bus.


(systemadm:4991): Bonobo-WARNING **: Bonobo must be initialized before use


Also the Require for at-spi2-atk should be added.
Comment 4 Lennart Poettering 2010-08-06 07:26:30 EDT
The bonobo/atspi messages are unrelated to systemd, and an issue with gtk in rawhide.

Since all systemd issues seem to be fixed now I'll close the bug now.

Note You need to log in before you can comment on or make changes to this bug.