Bug 620818 - SM cli and gui behave differently if we register candlepin 1 using standalone CA cert
Summary: SM cli and gui behave differently if we register candlepin 1 using standalone...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Candlepin
Classification: Community
Component: candlepin   
(Show other bugs)
Version: 0.5
Hardware: All Solaris
low
medium
Target Milestone: ---
: ---
Assignee: Bryan Kearney
QA Contact: wes hayutin
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 636830
TreeView+ depends on / blocked
 
Reported: 2010-08-03 14:59 UTC by spandey
Modified: 2015-05-14 15:22 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-23 16:15:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description spandey 2010-08-03 14:59:44 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
100%

Prerequisites :
candlepin : candlepin1.devlab.phx1.redhat.com
Client : Rhel6 client with sm version 73 

Steps to repro : 

Login to client console 
Enter path of standalone candlepin CA cert in rhsm.conf “candlepin_ca_file = /etc/candlepin/certs/candlepin-ca.crt”
try to register client to candlepin1 using user tmgedp/redhat

Expected Result : 
Registration process should fail with certificate error 

Actual Result : 
Successfully registered to candlepin1 
now we find different behavior for cli and gui  
subscription available check process is working for cli But not working for GUI

Comment 1 chris alfonso 2010-08-04 13:37:38 UTC
If the clients behave differently, I think this issue should go to pradeep or someone that works on the clients.

Comment 2 Bryan Kearney 2010-09-20 17:03:42 UTC
moving to new to make sure it gets picked up

Comment 3 James Bowes 2010-09-29 15:49:41 UTC
Was able to reproduce with 0.73, but not with master. looks like its already been fixed.

Comment 4 Jeff Weiss 2010-10-12 20:51:26 UTC
I get "certificate verify failed" errors in both cli and gui.  Commit ec83db148714fc71eece3af029e96c352fe2d14a

Comment 5 John Sefler 2010-11-23 16:15:24 UTC
This bug was opened/resolved/closed against the Entitlement-Alpha release.


Note You need to log in before you can comment on or make changes to this bug.