Bug 62083 - poweroff command does not turn off power.
poweroff command does not turn off power.
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-27 04:47 EST by Ivo Sarak
Modified: 2015-01-07 18:55 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-05 13:39:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivo Sarak 2002-03-27 04:47:31 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.0 (X11; Linux i686; U;) Gecko/20020311

Description of problem:
Result of poweroff command is not a shutdown of power to motherboard and other
devices. Message remaining on screen "Power down."

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Run a poweroff command.


Actual Results:  All devices are running and consuming power.

Expected Results:  Successful shutdown with turning off all devices.

Additional info:

Asustek A7M266-D with 2*AMD Athlon XP 1700+.

$ dmesg | grep apm
apm: BIOS version 1.2 Flags 0x03 (Driver version 1.16)
apm: disabled - APM is not SMP safe.
Comment 1 Preston Brown 2002-03-27 09:03:34 EST
Arjan:  Aren't we supposed to have fixed this?
Comment 2 Arjan van de Ven 2002-03-27 09:07:10 EST
No.

APM is rather non SMP safe (eg the words "SMP" or "multiprocessor" don't even
exist in the specification). However for poweroff you can make an exception:
add

apm=power-off
 
to the line with vmlinuz in it in /etc/grub/grub.conf
and you override the SMP check for apm. This is not done by default because
several bioses get it wrong and do Bad Things(tm).
Comment 3 Ivo Sarak 2002-03-27 09:31:59 EST
I think this is the case ofBad Things(tm):

apm: disabled - APM is not SMP safe (power off active)
is last message before hang.
Comment 4 Arjan van de Ven 2002-03-27 09:45:57 EST
Might be a good plan to check for a bios upgrade ;)
Comment 5 Ivo Sarak 2002-03-28 11:22:46 EST
I have installed the latest BIOS (1005d) to this board, but with no change.
Comment 6 John Bage 2002-07-02 16:50:23 EDT
I am having the same problem using KDE and Grub on RedHat Linux 7.3. I have 
even tried to do all the updates and even a complete reinstall of it but with 
no luck. It still continues to do this. I have also tried the bigmem, smp, and 
the regular kernels and the same problem still continues.
Comment 7 Adam Cowell 2002-08-19 21:35:51 EDT
I am now having this problem with Redhat 7.3 after one of the updates up2date
got.  It worked fine previously. Its a single CPU system and a Asus motherboard
a (A7V133). /sbin/shutdown -h now works fine though.
Comment 8 Alan Cox 2003-06-05 13:39:04 EDT
The AMD dual CPU doesn't support poweroff (APM isnt specified for SMP)

Note You need to log in before you can comment on or make changes to this bug.