Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 620839 - Spam gets hidden rather than removed from inbox
Spam gets hidden rather than removed from inbox
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: evolution (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Matthew Barnes
desktop-bugs@redhat.com
: RHELNAK
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-03 11:46 EDT by Gordan Bobic
Modified: 2010-08-03 12:28 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-03 12:28:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gordan Bobic 2010-08-03 11:46:35 EDT
Description of problem:
Evolution's handling of spam seems to be broken, at least with IMAP. Selecting a message and marking it as spam makes it disappear, as if it were deleted. But if you then log in from a different machine, the message is still there. Similarly, if on the machine where the message was marked, you:
rm -rf ~/.evolution/*
and start up evolution again, the spam message will re-appear in the inbox.

Version-Release number of selected component (if applicable):
evolution-2.28.3-8.el6.x86_64

How reproducible:
Every time.

Steps to Reproduce:
1. Mark a message as spam in inbox on an IMAP server (I only had dbmail back end handy to test with)

2. Connect to the IMAP server from a different machine or using a different client (e.g. Thunderbird). The spam message will appear to still be there, and not be deleted.

3. Do "rm -rf ~/.evolution/*". Start evolution again. The message will now also appear in evolution.

Actual results:
Spam message gets hidden on the machine where it was marked.

Expected results:
Spam should be deleted and/or moved to the Junk folder on the IMAP server.
Comment 2 RHEL Product and Program Management 2010-08-03 12:07:55 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 3 Matthew Barnes 2010-08-03 12:28:28 EDT
Not a bug, this is how Evolution is designed.

Marking a message as junk simply sets a flag on the message's meta data indicating it's junk.  The flag is also propagated to the IMAP server if possible, but there's no standard for this so other mailers may look for different meta data.  The message is not moved or marked for deletion, it's simply hidden from view in the message list.  The Junk folder is a virtual folder showing all messages in that account that have been flagged as junk.  It's up to the user to delete messages marked as junk.

Note You need to log in before you can comment on or make changes to this bug.