Bug 620841 - when installed RHATrhncfga, rhnreg_ks will crash with core dump
when installed RHATrhncfga, rhnreg_ks will crash with core dump
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Solaris (Show other bugs)
unspecified
All Linux
high Severity medium
: ---
: ---
Assigned To: Clifford Perry
Martin Minar
: Regression
Depends On:
Blocks: sat550-blockers sat550-post-ga/sat550-test-blockers
  Show dependency treegraph
 
Reported: 2010-08-03 11:51 EDT by Jiri Kastner
Modified: 2016-07-03 20:55 EDT (History)
4 users (show)

See Also:
Fixed In Version: rhn-solaris-bootstrap-5.3.4-1-sat
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-02 06:53:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Miroslav Suchý 2010-08-04 07:45:22 EDT
Minimalistic reproducer is:

# python
Python 2.4.1 (#1, Mar 14 2008, 04:08:13)
[GCC 3.3.2] on sunos5
Type "help", "copyright", "credits" or "license" for more information.
>>> import sys
>>> sys.path.append('/opt/redhat/rhn/solaris/lib/python2.4/site-packages/rhn/actions')
>>> file='ModeControllerCreator'
>>> __import__(file, {})
Fatal Python error: PyString_InternInPlace: strings only please!
Abort (core dumped)
bash-2.05# python -c "import sys;  sys.path.append('/opt/redhat/rhn/solaris/lib/python2.4/site-packages/rhn/actions'); file='ModeControllerCreator'; __import__(file);'
>
bash-2.05# python -c "import sys;  sys.path.append('/opt/redhat/rhn/solaris/lib/python2.4/site-packages/rhn/actions'); file='ModeControllerCreator'; __import__(file);"
Fatal Python error: PyString_InternInPlace: strings only please!

and when I touch ModeControllerCreator, things start working.
So it seems there is wrong .pyo files.
Comment 2 Miroslav Suchý 2010-08-04 08:18:31 EDT
That pkg file is created from el5 version where .pyc are created for python 2.6, whereas on Solaris is python 2.4.
Since rhel4 will be with us only limited amount of time,  we should rather do not .pyc files at all for Solaris.
Comment 3 Miroslav Suchý 2010-08-04 09:12:04 EDT
We will do not package .pyc and .pyo files. Commit b4692ff095f4d2895c2c8781ca89f2fb53799018

I rebuild rhncfg and rnpush and reupload them to barn.

Note You need to log in before you can comment on or make changes to this bug.