Bug 620851 - RHATpossl not linked with RHATossl package
RHATpossl not linked with RHATossl package
Status: CLOSED DEFERRED
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Solaris (Show other bugs)
unspecified
All Linux
low Severity medium
: ---
: ---
Assigned To: Miroslav Suchý
Jiri Kastner
: Regression
Depends On:
Blocks: 172657 462714
  Show dependency treegraph
 
Reported: 2010-08-03 12:08 EDT by Jiri Kastner
Modified: 2011-07-20 11:36 EDT (History)
3 users (show)

See Also:
Fixed In Version: rhn-solaris-bootstrap-5.3.5-1-sat
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-20 11:36:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiri Kastner 2010-08-03 12:08:33 EDT
Description of problem:
RHATpossl package requires libssl.so.0.9.7, but RHATossl provides libssl.so.0.9.7a

Version-Release number of selected component (if applicable):
RHATossl-0.9.7a-33.24.rhn.9.sol8.pkg

How reproducible:
always on sparc

Steps to Reproduce:
1. remove all sunfreeware openssl packages installed
2. install whole bootstrap on sparc solaris 5.9
3. run rhnreg_ks
4. ld.so.1 error regarding libssl.so.0.9.7
5. install latest openssl-0.9.7 from sunfreeware.com and remove RHATossl package
6. run rhnreg_ks
7. passed
  
Actual results:
ld.so.1 error

Expected results:
remove RHATossl from bootstrap, because satellite documentation for unix support notes sunfreeware.com as source for package deps (libgcc, zlib, gzip, openssl...), where are latest solaris 5.8+ openssl packages

Additional info:
Comment 1 Jan Pazdziora 2010-08-04 08:52:59 EDT
What's the ld.so.1 error?
Comment 2 Jan Pazdziora 2010-08-04 08:54:41 EDT
By the way, the ossl/possl issue was last (to my knowledge) addressed in bug 467274 and based on bug 467274 comment 19, you need to have our possl and our ossl. That bugzilla got VERIFIED and released, so please check that the current errata/package you are workign with don't have some other regression of some sort.
Comment 3 Jiri Kastner 2010-08-04 11:53:24 EDT
RHATossl-0.9.7a-33.24.rhn.2.sol8.pkg:
pkgchk -v RHATossl 2>&1 | grep lib
/opt/redhat/rhn/solaris/lib
/opt/redhat/rhn/solaris/lib/libcrypto.so.0.9.7a
/opt/redhat/rhn/solaris/lib/libcrypto.so.4
/opt/redhat/rhn/solaris/lib/libssl.so.0.9.7a
/opt/redhat/rhn/solaris/lib/libssl.so.4
/opt/redhat/rhn/solaris/share/ssl/lib

RHATossl-0.9.7a-33.24.rhn.9.sol8.pkg:
pkgchk -v RHATossl 2>&1 | grep lib
/opt/redhat/rhn/solaris/lib
/opt/redhat/rhn/solaris/lib/libcrypto.so.0.9.7
/opt/redhat/rhn/solaris/lib/libcrypto.so.0.9.7a
/opt/redhat/rhn/solaris/lib/libssl.so.0.9.7
/opt/redhat/rhn/solaris/lib/libssl.so.0.9.7a
/opt/redhat/rhn/solaris/share/ssl/lib

bash-2.05# gzip -dc /rhn-solaris-bootstrap-5.3.3-1-sparc-sol9.tar.gz | tar tf - | grep RHATossl
rhn-solaris-bootstrap-5.3.3-1-sparc-sol9/RHATossl-0.9.7a-33.24.rhn.2.sol8.pkg
bash-2.05# gzip -dc /rhn-solaris-bootstrap-5.3.2-1-sparc-sol9.tar.gz | tar tf - | grep RHATossl
rhn-solaris-bootstrap-5.3.2-1-sparc-sol9/RHATossl-0.9.7a-33.24.rhn.2.sol8.pkg
bash-2.05# gzip -dc /rhn-solaris-bootstrap-5.3.0-10-sparc-sol9.tar.gz | tar tf - | grep RHATossl
rhn-solaris-bootstrap-5.3.0-10-sparc-sol9/RHATossl-0.9.7a-33.24.rhn.9.sol8.pkg
Comment 4 Jan Pazdziora 2010-08-05 03:28:15 EDT
So, what's the ld.so.1 error?
Comment 5 Jiri Kastner 2010-08-05 04:10:34 EDT
ImportError: ld.so.1: /opt/redhat/rhn/solaris/bin/python: fatal:
libssl.so.0.9.7: open failed: No such file or directory;
Comment 6 Miroslav Suchý 2010-08-05 08:34:05 EDT
update to recent RHATossl
44a21dc4669842375f5444236ae73cfd0c464e2a

Note You need to log in before you can comment on or make changes to this bug.