Bug 620859 - radeon_tex_copy.c:73: do_copy_texsubimage: Assertion `rrb && rrb->bo' failed.
radeon_tex_copy.c:73: do_copy_texsubimage: Assertion `rrb && rrb->bo' failed.
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: mesa (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Jérôme Glisse
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-03 12:24 EDT by Michal Hlavinka
Modified: 2011-06-28 11:02 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-28 11:02:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Hlavinka 2010-08-03 12:24:31 EDT
Description of problem:
I've tried to run StarCraft 2 under wine, but got following crash:

radeon_tex_copy.c:73: do_copy_texsubimage: Assertion `rrb && rrb->bo' failed.

I'm not sure whether this is wine/mesa/xorg-x11-drv-ati/somethin else bug, but I've found mesa bug report:

http://bugs.freedesktop.org/show_bug.cgi?id=27009

that looks very similar, but it's already closed as fixed

My ati vga:
01:00.0 VGA compatible controller [0300]: ATI Technologies Inc M92 [Mobility Radeon HD 4500 Series] [1002:9553]

Version-Release number of selected component (if applicable):
mesa-*-7.8.1-7.fc13
xorg-x11-drv-ati-6.13.0-2.fc13.x86_64

How reproducible:
always

Steps to Reproduce:
1.install starcraft 2
2.run it
3.
  
Actual results:
after a few seconds with "loading" screen it crashes

Expected results:
no crash

Additional info:
Comment 1 Thomas Spear 2010-08-03 18:05:47 EDT
No crash for me with SC2 with wine-1.2.0-1 or wine-1.2.0-2 but I am using NVidia card.

Possibly fixed upstream but not in rh mesa driver?
Comment 2 Michal Hlavinka 2010-08-04 02:42:57 EDT
I've built yesterday's snapshot of mesa and it was "working" fine. I got no mesa assert crash, but 1fps which is not usable. It seems ati drivers are not good enough, because I've heard several times it works with nvidia,
Comment 3 Manuel F Martinez 2010-10-13 05:09:53 EDT
I tried to run some games on wine, but I found this issue with Spiderman-PC from Activision.

I've tested with wine-1.3.4-202-g47d2a00 build from git repository.

My ATI VGA:
01:05.0 VGA compatible controller: ATI Technologies Inc RS480 [Radeon Xpress 200G Series] (prog-if 00 [VGA controller])

CPU:
AMD Athlon(tm) 64 Processor 3700+

mesa-dri-drivers-7.8.1-8.fc13.i686
xorg-x11-drv-ati-6.13.0-1.fc13.i686

Fedora 13 Kernel: 2.6.34.7-56.fc13.i686.PAE

How reproducible:
always

Steps to Reproduce:
1.install Spiderman-PC from Activision website
2.run it

So I'm confirming this issue is still on Fedora 13.

Thanks
Comment 4 Bug Zapper 2011-06-01 08:11:55 EDT
This message is a reminder that Fedora 13 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 13.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '13'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 13's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 13 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Bug Zapper 2011-06-28 11:02:11 EDT
Fedora 13 changed to end-of-life (EOL) status on 2011-06-25. Fedora 13 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.