This service will be undergoing non-disruptive maintenance at 07:20 UTC, 2018-12-14. It is expected to last approximately 30 minutes
Bug 62089 - Postinstall script fails to create files
Summary: Postinstall script fails to create files
Status: CLOSED CANTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: jadetex (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: noarch Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-03-27 11:39 UTC by frankie
Modified: 2007-04-18 16:41 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-16 16:42:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description frankie 2002-03-27 11:39:11 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [es] (X11; U; Linux 2.4.17 i686)

Description of problem:
When I run db2pdf it fails to find the file pdfjadetex.fmt.
I found out this file is from the package jadetex and it's supposed to be
created
in the postinstall script. It's not there and it's not created when I run the
commands
from the script manually.


Version-Release number of selected component (if applicable):
jadetex-3.11-4.noarch.rpm
I also tried jadetex-3.12-2.noarch.rpm from rawhide but it's worse.

How reproducible:
Always

Steps to Reproduce:
1. Install jadetex
2. ls -ld /usr/share/texmf/web2c/pdfjadetex.fmt


Actual Results:  file not found

Expected Results:  the file should be there

Additional info:

I upgraded all the tetex packages to 1.0.7-38.2.
Here is an extract of the output of the postinstall script.
It looks like a problem about pzdr.

# /usr/bin/env - PATH=$PATH:/usr/bin fmtutil --cnffile
/usr/share/texmf/tex/jadetex/jadefmtutil.cnf --all

(/usr/share/texmf/tex/latex/psnfss/upzd.fd)kpathsea: Running mktextfm  pzdr
mktextfm: Running mf \mode:=ljfour; mag:=1; nonstopmode; input pzdr
This is METAFONT, Version 2.7182 (Web2C 7.3.1)

kpathsea: Running mktexmf  pzdr
! I can't find file `pzdr'.
<*> \mode:=ljfour; mag:=1; nonstopmode; input pzdr
                                                  
Please type another input file name

Comment 1 Tim Waugh 2002-04-02 09:21:08 UTC
What is your TEXINPUTS environment variable set to?

Comment 2 frankie 2002-04-02 10:38:08 UTC
I have no such variable in my environment. I also run the postinstall and then I
checked
the env.

Comment 3 Tim Waugh 2002-04-02 10:43:59 UTC
Please list all tetex packages you have (rpm -qa | grep ^tetex).  Thanks.

Comment 4 Tim Waugh 2005-09-16 16:42:21 UTC
No feedback; closing.


Note You need to log in before you can comment on or make changes to this bug.