Bug 620949 - [abrt] gnome-panel-2.31.4-3.fc14: Process /usr/bin/gnome-panel was killed by signal 11 (SIGSEGV)
[abrt] gnome-panel-2.31.4-3.fc14: Process /usr/bin/gnome-panel was killed by ...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-panel (Show other bugs)
14
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
abrt_hash:144c7bcaff23d40fad7a57897a9...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-03 16:25 EDT by Felix Möller
Modified: 2011-01-20 07:24 EST (History)
5 users (show)

See Also:
Fixed In Version: glib2-2.25.11-1.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-20 07:24:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (13.85 KB, text/plain)
2010-08-03 16:25 EDT, Felix Möller
no flags Details

  None (edit)
Description Felix Möller 2010-08-03 16:25:12 EDT
abrt version: 1.1.10
architecture: i686
Attached file: backtrace
cmdline: gnome-panel
component: gnome-panel
executable: /usr/bin/gnome-panel
kernel: 2.6.35-0.57.rc6.git1.fc14.i686.PAE
package: gnome-panel-2.31.4-3.fc14
rating: 3
reason: Process /usr/bin/gnome-panel was killed by signal 11 (SIGSEGV)
release: Fedora release 14 (Branched)
How to reproduce: log in
time: 1280867100
uid: 500
Comment 1 Felix Möller 2010-08-03 16:25:16 EDT
Created attachment 436374 [details]
File: backtrace
Comment 2 Felix Möller 2010-08-03 17:48:09 EDT
gnome panel crashes more than 20 times a second.

This causes the desktop to move up by the hight of the panel every time. An maximized windows are shaking ...

I installed the glib2 update, but this did not help ...

I have 


(gnome-panel:30831): GLib-GIO-CRITICAL **: g_dbus_connection_signal_subscribe: assertion `callback != NULL' failed


in my .xsession error
Comment 3 Felix Möller 2010-08-03 18:11:24 EDT
This is solved by installing glib2-2.25.11-1.fc14.i686.rpm.

I tried glib2-2.25.12-2.fc14 from koji and this does not solve the issue.

Thanks alot for nirik on IRC for the suggestion to try glib2 ....
Comment 4 Felix Möller 2010-08-03 18:13:00 EDT
moving to glib2 component ...
Comment 5 Felix Möller 2010-08-04 03:50:39 EDT
This bug is set to be fixed with glib2-2.25.11-1.fc14. But please recognize that this has been a regression from glib2-2.25.11-1.fc14 to glib2-2.25.12-1.fc14 therefore it is broken currently.
Comment 6 Matthias Clasen 2010-08-04 07:50:46 EDT
I'm waiting for a buildroot override to build a fixed gnome-panel.
Comment 7 James Laska 2010-08-04 12:31:15 EDT
(In reply to comment #6)
> I'm waiting for a buildroot override to build a fixed gnome-panel.    

Going through the blocker list and review status of bugs.  This appears to have just been tagged by rel-eng (see https://fedorahosted.org/rel-eng/ticket/3928).
Comment 8 John Poelstra 2010-08-04 12:51:57 EDT
working towards a fix, changing to ASSIGNED
Comment 9 John Poelstra 2010-08-05 12:43:43 EDT
What are the next steps and plans for fixing this bug?  Can someone please provide more inofrmation?

If this is in fact a blocker we can't compose the Fedora 14 Alpha Release Candidate today unless it is fixed.
Comment 10 Matthias Clasen 2010-08-05 12:53:00 EDT
Waiting for 

https://admin.fedoraproject.org/updates/glib2-2.25.12-2.fc14,gnome-panel-2.31.6-1.fc14

to get out of testing. Let me add the bug to the update, even though that is not literally correct.
Comment 11 Fedora Update System 2010-08-05 12:53:53 EDT
glib2-2.25.12-2.fc14,gnome-panel-2.31.6-1.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/glib2-2.25.12-2.fc14,gnome-panel-2.31.6-1.fc14
Comment 12 Paul W. Frields 2010-08-05 13:25:32 EDT
I asked in the update at http://admin.fedoraproject.org/updates/glib2-2.25.12-2.fc14,gnome-panel-2.31.6-1.fc14 whether that update (both packages) can be pushed to stable given the level of testing -- two people, plus one more proventester -- in order to clear this blocker.
Comment 13 James Laska 2010-08-05 15:02:10 EDT
Moving ON_QA since there is an update available for this fix.  Not sure why bodhi didn't change the state.
Comment 15 Fedora Update System 2010-08-09 21:28:29 EDT
glib2-2.25.13-1.fc14, gnome-panel-2.31.6-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update glib2 gnome-panel'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/glib2-2.25.13-1.fc14,gnome-panel-2.31.6-1.fc14
Comment 16 Adam Williamson 2010-08-11 17:24:03 EDT
Alpha RC3, as we intended, includes the old version of glib2 and gnome-panel, so this crash - along with other issues introduced by the new glib2 - is avoided. I have verified that there's no crashes with gnome-panel when booting the RC3 desktop live image. So this no longer blocks Alpha.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.