Bug 621012 - Automatic proxy configuration should default to http://wpad/wpad.dat
Summary: Automatic proxy configuration should default to http://wpad/wpad.dat
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: control-center   
(Show other bugs)
Version: 13
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Control Center Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-04 00:32 UTC by Jason Haar
Modified: 2011-02-08 01:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-08 01:11:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jason Haar 2010-08-04 00:32:31 UTC
Description of problem:

On our world-wide WAN, we're big users of WPAD as a means to ensure our users use the closest proxy server to their physical location. "control-center" allows you to configure the use of WPAD via entering the appropriate URL - but it has no default.

In reality, most real users would not know what the URL is (only the IT geeks do), so they don't know what to even type in. I think control-center should default to http://wpad/wpad.dat - the user could override it in the corner-case exceptions - but it would mean it would work out of the box. 

 
Version-Release number of selected component (if applicable):

control-center-2.30.1-2.fc3

How reproducible:

always - as long back as I can remember 

Steps to Reproduce:
1. System->Prefs->Network Proxy
2.
3.
  
Actual results:

no default

Expected results:

should default to http://wpad/wpad.dat

Additional info:

Obviously this is a feature request - hopefully this is the correct way to make them :-)

Comment 1 Bastien Nocera 2011-02-08 01:11:28 UTC
Moved bug upstream:
https://bugzilla.gnome.org/show_bug.cgi?id=641793


Note You need to log in before you can comment on or make changes to this bug.