Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 621033 - Environment variable in /etc/sysconfig/atop is not reflected
Environment variable in /etc/sysconfig/atop is not reflected
Status: CLOSED DUPLICATE of bug 609124
Product: Fedora EPEL
Classification: Fedora
Component: atop (Show other bugs)
el5
All Linux
low Severity low
: ---
: ---
Assigned To: Kairo Francisco de Araujo
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-04 00:01 EDT by Raina Otoni
Modified: 2010-08-09 07:31 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-09 07:31:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Raina Otoni 2010-08-04 00:01:07 EDT
Description of problem:
Environment variable in /etc/sysconfig/atop is not reflected.

Version-Release number of selected component (if applicable):
1.23-8

How reproducible:
change variable in /etc/sysconfig/atop, and restart atop

Steps to Reproduce:
1. Modify INTERVAL to 60
2. service atop restart
3. $ ps auxww|grep atop

  
Actual results:
/usr/bin/atop -a -w /var/log/atop/atop_20100804 600

Expected results:
/usr/bin/atop -a -w /var/log/atop/atop_20100804 60

Additional info:
The environment variables is overwritten in followings.
 /usr/bin/atopd
 /etc/cron.daily/atop

I have changed operator from || to &&, then it works correctly.
- [ -z $INTERVAL ] ||  INTERVAL=600
+ [ -z $INTERVAL ] &&  INTERVAL=600
Comment 1 Alex Samorukov 2010-08-09 04:37:35 EDT
looks like ti be a duplicate of the https://bugzilla.redhat.com/show_bug.cgi?id=609124
Comment 2 Raina Otoni 2010-08-09 07:31:02 EDT
Thanks. This bug is duplicate.

*** This bug has been marked as a duplicate of bug 609124 ***

Note You need to log in before you can comment on or make changes to this bug.