Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 621045 - Some nmap options missing in "nmap --help" output
Some nmap options missing in "nmap --help" output
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: nmap (Show other bugs)
6.0
All Linux
low Severity low
: rc
: ---
Assigned To: Michal Hlavinka
Aleš Mareček
:
Depends On:
Blocks: 743506
  Show dependency treegraph
 
Reported: 2010-08-04 01:59 EDT by Karel Srot
Modified: 2011-10-05 03:26 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Prior to this update, the output of the "nmap -h" (or "nmap --help") command did not describe all the available nmap options that begin with the "-s" or "-P" prefix. As a result, a user could have been unable to research what options can be used to perform specific tasks with nmap. With this update, the bug has been fixed so that the output of "nmap -h" now describes all the aforementioned nmap options that were previously missing from the output.
Story Points: ---
Clone Of:
: 743506 (view as bug list)
Environment:
Last Closed: 2011-07-20 08:48:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:0967 normal SHIPPED_LIVE nmap bug fix update 2011-07-20 08:48:19 EDT

  None (edit)
Description Karel Srot 2010-08-04 01:59:51 EDT
Description of problem:

nmap-5.21-3.el6.x86_64

options listed in manpage but missing in "nmap --help" output:
	--allports
	--defeat-rst-ratelimit
	--fuzzy
	--help
	--initial-rtt-timeout
	--interactive
	--max-hostgroup
	--max-os-tries
	--max-parallelism
	--max-rtt-timeout
	--randomize-hosts
	--release-memory
	--servicedb
	--state
	--stats-every
	--syn
	--version
	--versiondb
	-PR
	-sR
Comment 1 Michal Hlavinka 2010-08-04 03:04:11 EDT
last line of the help output is:
> SEE THE MAN PAGE (http://nmap.org/book/man.html) FOR MORE OPTIONS AND EXAMPLES

it states there are more options than just those written by nmap --help, so why do you consider this as a bug?
Comment 2 Karel Srot 2010-08-04 03:17:01 EDT
Yep, that's true. Anyway, I think at least -PR, -sR options should be listed since other -P -s variants are present. That's just my opinion, not an order.
Comment 3 Suzanne Yeghiayan 2011-02-15 16:41:28 EST
This issue was proposed for RHEL 6.1 FasTrack but did not get resolved in time.
It has been moved to RHEL 6.2 FasTrack.
Comment 5 Suzanne Yeghiayan 2011-02-15 17:04:55 EST
This issue was proposed for RHEL 6.1 FasTrack but did not get resolved in time.
It has been moved to RHEL 6.2 FasTrack.
Comment 8 Petr Kovar 2011-07-04 13:00:06 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Prior to this update, the output of the "nmap -h" (or "nmap --help") command did not describe all the available nmap options that begin with the "-s" or "-P" prefix. As a result, a user could have been unable to research what options can be used to perform specific tasks with nmap. With this update, the bug has been fixed so that the output of "nmap -h" now describes all the aforementioned nmap options that were previously missing from the output.
Comment 10 errata-xmlrpc 2011-07-20 08:48:24 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0967.html

Note You need to log in before you can comment on or make changes to this bug.