Bug 621102 - The installer doesn't use packages repository in DVD as default
Summary: The installer doesn't use packages repository in DVD as default
Status: CLOSED DUPLICATE of bug 609049
Alias: None
Product: Fedora
Classification: Fedora
Component: udev   
(Show other bugs)
Version: 14
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: F14Alpha, F14AlphaBlocker
TreeView+ depends on / blocked
 
Reported: 2010-08-04 09:25 UTC by He Rui
Modified: 2010-08-20 19:30 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-06 16:40:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs under /tmp (346.94 KB, application/x-gzip)
2010-08-04 09:25 UTC, He Rui
no flags Details

Description He Rui 2010-08-04 09:25:17 UTC
Created attachment 436478 [details]
logs under /tmp

Description of problem:

When installing F14_Alpha_TC2_DVD_x86_64.iso, At the package selection step, the installer didn't use the repo in DVD as default but retrieved and then used the repo of rawhide mirror link.  

PS: When I tried to add the DVD repo manually, it said that no installation media was found.

Version-Release number of selected component (if applicable):
anaconda 14.14
F14_Alpha_TC2_DVD_x86_64.iso

How reproducible:
100%

Steps to Reproduce:
1. Virt-install F14_Alpha_TC2_DVD_x86_64.iso
2. Advance to the Package selection step with default settings.
 

Expected results:
Use DVD repo instead.

Comment 1 Chris Lumens 2010-08-04 15:34:38 UTC
This is our old friend,

AttributeError: "'DeviceFormat' object has no method 'mount'"

which happens because our /dev/sr0 object is getting DeviceFormat instead of some more specific format.  And that happens because the udev info block for sr0 has no ID_FS_TYPE.

Comment 2 He Rui 2010-08-06 03:19:54 UTC
Consider it as F14Alpha blocker due to:

6.The installer must be able to use the DVD local package source options (https://fedoraproject.org/wiki/Fedora_14_Alpha_Release_Criteria)

Comment 3 Harald Hoyer 2010-08-06 15:00:18 UTC
Is this in qemu? If yes, then it could be bug 609049

Comment 4 James Laska 2010-08-06 16:03:24 UTC
(In reply to comment #3)
> Is this in qemu? If yes, then it could be bug 609049    

I believe so.  This is easy to recreate by installing F-14-Alpha RC1 i386 from a DVD using libvirt and virt-manager.  The end result is that anaconda cannot find the DVD package repo, it enables the online repos.

This is bad because ...
 1) Requires internet access to complete the virt DVD install (no offline install)
 2) The online repos often contain deps/conflicts problems

Are there any straight forward documentable workarounds for this issue?

Comment 5 Adam Williamson 2010-08-06 16:40:05 UTC
Discussed at 2010/08/06 blocker meeting. We believe this is caused by 609049 indeed, and hence occurs only when installing in virt-manager, and possibly only on an F14 host. It therefore doesn't count as an Alpha blocker as the virt release criteria kick in at Beta stage. Will mark this as a dupe of 609049 and mark that as an AcceptedBlocker for Beta. This will be documented on the Common Bugs page.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 609049 ***

Comment 6 François Cami 2010-08-08 13:48:56 UTC
Reproduced on a F13 host. See bug 609049 for a workaround using virt-install.

Comment 7 Adam Williamson 2010-08-20 19:30:19 UTC
no need to commonbugs this, it got fixed for alpha.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers


Note You need to log in before you can comment on or make changes to this bug.