Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 621118 - pdf2ps segfaults on bad PDF
pdf2ps segfaults on bad PDF
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ghostscript (Show other bugs)
6.0
All Linux
low Severity high
: rc
: ---
Assigned To: Tim Waugh
QE Internationalization Bugs
: Patch
Depends On: 501710 503785
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-04 06:13 EDT by Tim Waugh
Modified: 2011-05-19 08:28 EDT (History)
2 users (show)

See Also:
Fixed In Version: ghostscript-8.70-7.el6
Doc Type: Bug Fix
Doc Text:
Previously, including a large JBIG2 compressed image in the PDF input file could cause the pdf2ps conversion utility to terminate unexpectedly with a segmentation fault. This was caused by the fact that the result of the "jbig2_image_new" function call was not always checked properly. This error has been fixed, and the inclusion of JBIG2 images no longer causes pdf2ps to crash.
Story Points: ---
Clone Of: 501710
Environment:
Last Closed: 2011-05-19 08:28:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:0527 normal SHIPPED_LIVE ghostscript bug fix update 2011-05-18 13:57:49 EDT

  None (edit)
Comment 2 Tim Waugh 2010-11-26 07:32:10 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Previously, including a large JBIG2 compressed image in the PDF input file may have caused the pdf2ps conversion utility to terminate unexpectedly with a segmentation fault. This was caused by the fact that the result of the "jbig2_image_new" function call was not always checked properly. This error has been fixed, and the inclusion of JBIG2 images no longer results in a segmentation fault.
Comment 5 Jaromir Hradilek 2011-02-18 06:44:00 EST
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1 @@
-Previously, including a large JBIG2 compressed image in the PDF input file may have caused the pdf2ps conversion utility to terminate unexpectedly with a segmentation fault. This was caused by the fact that the result of the "jbig2_image_new" function call was not always checked properly. This error has been fixed, and the inclusion of JBIG2 images no longer results in a segmentation fault.+Previously, including a large JBIG2 compressed image in the PDF input file could cause the pdf2ps conversion utility to terminate unexpectedly with a segmentation fault. This was caused by the fact that the result of the "jbig2_image_new" function call was not always checked properly. This error has been fixed, and the inclusion of JBIG2 images no longer causes pdf2ps to crash.
Comment 6 errata-xmlrpc 2011-05-19 08:28:09 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0527.html

Note You need to log in before you can comment on or make changes to this bug.