Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 621157 - http basic auth does not work?
http basic auth does not work?
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: agedu (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Susi Lehtola
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-04 08:03 EDT by lejeczek
Modified: 2010-08-04 09:22 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-04 09:05:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description lejeczek 2010-08-04 08:03:52 EDT
Description of problem:
I can generate, using htpasswd, a password file, starting with plain-text passwords and every other encryption type, yet agedu --auth basic --auth-file does not authenticate, just keeps popping up and asks to submit user & password


Version-Release number of selected component (if applicable):
0-1.r8768.fc13

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Susi Lehtola 2010-08-04 08:26:41 EDT
I was able to reproduce this. Reporting upstream.
Comment 2 Susi Lehtola 2010-08-04 09:05:19 EDT
Looks like my problem was caused by having a newline character at the end of the password file, after all. htpasswd puts in a newline character at the end, so you're experiencing the same problem.

Create the password file with e.g.
 $ echo -n "user:pass" > passwd
and then it will work.
Comment 3 lejeczek 2010-08-04 09:22:19 EDT
yep indeed, thanks for this, nice one.

Note You need to log in before you can comment on or make changes to this bug.