Bug 621166 - RFE: add options like timeout for spacewalk-repo-sync
RFE: add options like timeout for spacewalk-repo-sync
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: Server (Show other bugs)
1.0
All Linux
low Severity high
: ---
: ---
Assigned To: Michael Mráka
Red Hat Satellite QA List
:
Depends On:
Blocks: spacewalk-rfe
  Show dependency treegraph
 
Reported: 2010-08-04 08:23 EDT by Frederic
Modified: 2011-12-23 05:02 EST (History)
4 users (show)

See Also:
Fixed In Version: spacewalk-backend-1.6.53-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-23 05:02:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frederic 2010-08-04 08:23:46 EDT
Description of problem:

I am using Spacewalk behind proxies.  I want to syncronize a channel in my Spacewalk by running spacewalk-repo-sync but this command does not care about /etc/yum.conf "timeout" setting.

To reproduct the problem, you can run this command: /usr/bin/spacewalk-repo-sync --channel myChannel --url http://aWebServer/mirror/centos.org/5/updates/i386/ --type yum

Downloading problematic file from the same source using wget on the same machine works well.

The actual result is no way to syncronize because of timeout.


regards,

Frédéric
Comment 1 Jan Pazdziora 2010-10-27 04:31:57 EDT
Mass-aligning under space12, so that we don't lose track of this bugzilla. This however does not mean that we plan (will be able to) address this bug in Spacewalk 1.2.
Comment 2 Jan Pazdziora 2010-11-19 11:04:38 EST
Mass-moving to space13.
Comment 3 Miroslav Suchý 2011-04-11 03:33:12 EDT
We did not have time for this one during Spacewalk 1.4 time frame. Mass moving to Spacewalk 1.5.
Comment 4 Miroslav Suchý 2011-04-11 03:37:04 EDT
We did not have time for this one during Spacewalk 1.4 time frame. Mass moving to Spacewalk 1.5.
Comment 5 Jan Pazdziora 2011-07-20 07:51:23 EDT
Aligning under space16.
Comment 6 Jan Pazdziora 2011-09-16 10:37:53 EDT
Michael, is spacewalk-repo-sync supposed to use /etc/yum.conf content? Do we have an alternative way of specifying timeouts for spacewalk-repo-sync?
Comment 7 Michael Mráka 2011-09-21 03:02:53 EDT
Well definitely not, /etc/yum.conf is server's yum configuration file, i.e. what's matter when you do 'yum update'.

While spacewalk-repo-sync is spacewalk's (the application) stuff. We'd better introduce our own configuration file e.g. /etc/rhn/spacewalk-repo-sync/yum_src.conf or something like that if there's need for it. And better not mix up server's and application's stuff, they might have very different needs for the same option.
Comment 8 Jan Pazdziora 2011-09-21 03:14:57 EDT
(In reply to comment #7)
> Well definitely not, /etc/yum.conf is server's yum configuration file, i.e.
> what's matter when you do 'yum update'.
> 
> While spacewalk-repo-sync is spacewalk's (the application) stuff. We'd better
> introduce our own configuration file e.g.
> /etc/rhn/spacewalk-repo-sync/yum_src.conf or something like that if there's
> need for it. And better not mix up server's and application's stuff, they might
> have very different needs for the same option.

Right.

In any case, spacewalk-repo-sync not caring about /etc/yum.conf is expected and correct thing to do.

While the initial description is NOTABUG, let's keep this bugzilla open as an RFE, to add the possibility to configure similar things. I might prefer to have this configured in the database rather than in the config file -- you might want to have different timeout/proxy/whatever values for different repositories, so it's best kept close to those repositories data-wise.
Comment 9 Frederic 2011-09-21 03:18:02 EDT
I did report this bug because spacewalk-repo-sync man page tells that the only current supported type is yum. see --type=yum
Comment 10 Jan Pazdziora 2011-09-21 03:44:13 EDT
(In reply to comment #9)
> I did report this bug because spacewalk-repo-sync man page tells that the only
> current supported type is yum. see --type=yum

That's correct. But as Michael explained in comment 7, while both yum the system updater and spacewalk-repo-sync might use the same libraries from the yum package, the /etc/yum.conf is only meant to configure yum (the system updater). We currently don't have the equivalent of /etc/yum.conf for spacewalk-repo-sync.
Comment 11 Frederic 2011-09-21 03:55:17 EDT
I'm OK with what you said.  Maybe just add proxy and timeout parameters to spacewalk-repo-sync command. ex.: --proxy= and --timeout=
Comment 14 Michael Mráka 2011-12-06 08:11:20 EST
This feature has been implemented in Spacewalk nightly.
You can put yum related options for spacewalk-repo-sync to /etc/rhn/spacewalk-repo-sync/yum.conf.


Spacewalk master commits
commit 85799c76c24077c3466e965059174f04959e1507
    621166 - reuse YumBase instance from __init__
commit 725b6b34ee153add2c7ed3db1871362d8342e91d
    621166 - notice config file in man page
commit 0292816165b447b718edcb7ad3632baffaba8ddb
    621166 - let's enable yum_src tuning (via config file)
    anyway yum options for spacewalk-repo-sync should not interfere with
    machine's yum i.e. /etc/yum.conf; thus separate config file
Comment 15 Milan Zazrivec 2011-12-23 05:02:10 EST
Spacewalk 1.6 has been released.

Note You need to log in before you can comment on or make changes to this bug.