Bug 621205 - Fullscreen problems in presentation mode in OpenOffice-Impress when running Compiz (Fusion or stock)
Fullscreen problems in presentation mode in OpenOffice-Impress when running C...
Status: CLOSED DUPLICATE of bug 623191
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On: 623191
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-04 10:17 EDT by Gian Paolo Mureddu
Modified: 2010-09-09 05:11 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-09 05:11:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 110881 None None None Never
OpenOffice.org 113809 None None None Never

  None (edit)
Description Gian Paolo Mureddu 2010-08-04 10:17:19 EDT
Description of problem:

There is a problem with the presentation mode in OpenOffice-Impress when running Compiz as the composite manager (with GTK-Decorator) in that the title bar of the OpenOffice window, the bottom and upper panels not being covered by the presentation and content being displayed "behind" these elements. This does not happen when running Metacity (though I have not tried with Metacity's composite manager).

Version-Release number of selected component (if applicable):

openoffice.org-impress-3.2.0-12.25.fc13.x86_64

How reproducible:

Always. Thus far I have only tried with the x86_64 version.

Steps to Reproduce:
1. Open a new presentation (.odt, .ppt, etc)
2. Make sure you are running Compiz (System → Preferences → Desktop Effects)
3. Start the presentation.
  
Actual results:

The presentation screen falls behind the panels and the title bar of the active OpenOffice window.

Expected results:

The presentation screen to cover the panel and window title bar GUI elements, despite of being running Compiz (as is the case with Fedora's 12 OpenOffice-Impress which does not exhibit this behaviour)
Comment 1 Caolan McNamara 2010-08-10 06:18:18 EDT
There should be a window manager compliance suite in order to bring sanity to the madness :-(
Comment 2 Alexjan Carraturo 2010-09-01 03:30:40 EDT
I have the same problem, and I think it's something connected to "Compiz".

I saw that even Ubuntu user have the same trouble; https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/525807 .

I have tried solutions suggested here, but without any result.
Comment 3 Caolan McNamara 2010-09-09 05:11:11 EDT

*** This bug has been marked as a duplicate of bug 623191 ***

Note You need to log in before you can comment on or make changes to this bug.