Bug 62121 - bison 1.34 incompatible with C++ compilers
bison 1.34 incompatible with C++ compilers
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: bison (Show other bugs)
skipjack-beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
http://bugs.debian.org/cgi-bin/bugrep...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-27 12:50 EST by Christian Bauer
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-27 12:50:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Bauer 2002-03-27 12:50:09 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.9-31 i686)

Description of problem:
Parsers generated with version 1.34 of bison cannot be compiled with C++
compilers when YYSTYPE is a class. This breaks many C++ projects that use bison.
I recommend updating the package to bison 1.35 where the problem has been fixed.
For all the gory details, see the given URL.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
An example of a project that breaks because of this:
1. Download GiNaC sources from www.ginac.de (and install CLN if you
   haven't already done so)
2. ./configure
3. rm ginsh/ginsh_parser.cc [to force a rerun of bison]
4. make


Actual Results:  Compilation in the "ginsh" directory fails with the message
/usr/share/bison/bison.simple:75: member `GiNaC::ex yyalloc::yyvs' with 
constructor not allowed in union


Expected Results:  A clean compile (as is the case with bison-1.28-7 from RedHat
7.2).


Additional info:

For all the gory details, see
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=130914&repeatmerged=yes
Comment 1 Ngo Than 2002-03-27 14:31:17 EST
update 1.35 in rawhide, thanks

Note You need to log in before you can comment on or make changes to this bug.