Bug 621276 - Error on deleting large repos using the repo delete option
Summary: Error on deleting large repos using the repo delete option
Status: CLOSED DUPLICATE of bug 620495
Alias: None
Product: Pulp
Classification: Retired
Component: z_other   
(Show other bugs)
Version: unspecified
Hardware: All Linux
low
medium
Target Milestone: ---
: ---
Assignee: Pradeep Kilambi
QA Contact: Preethi Thomas
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-04 16:25 UTC by Preethi Thomas
Modified: 2011-07-15 19:33 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 620495
Environment:
Last Closed: 2010-08-17 14:43:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Preethi Thomas 2010-08-04 16:25:15 UTC
+++ This bug was initially created as a clone of Bug #620495 +++

Cloning this to make the repo delete as a separate issue

Description of problem:

pulp repo delete failing when you try to delete a large repo

I created & synced f13 repo

[root@preethi pulp]# pulp repo -u admin -p admin sync --id=f13-2
Sync Status:: running
Sync Status:: running
Sync Status:: running
Sync Status:: running
Sync Status:: running
Sync Status:: running
Sync Status:: running
Sync Status:: running
Sync Status:: running
Sync Status:: finished
 Sync Successful. Repo [ f13-2 ] now has a total of [ 3102 ] packages


Now if I try to delete repo

[root@preethi pulp]# pulp -u admin -p admin repo delete --id=f13-2
 Deleted operation failed on Repo [ f13-2 ] 

[root@preethi ~]# tail -f /var/log/pulp/pulptools.log

cert_file: None and key_file: None
2010-08-04 12:27:03,542 [ERROR][MainThread] _delete() @ core_repo.py:206 - Error: 500: "Traceback (most recent call last):\n  File \"/usr/lib/python2.6/site-packages/pulp/webservices/controllers/base.py\", line 50, in report_error\n    return method(self, *args, **kwargs)\n  File \"/usr/lib/python2.6/site-packages/pulp/webservices/role_check.py\", line 97, in check_roles\n    ret=f(instance, *fargs, **kw)\n  File \"/usr/lib/python2.6/site-packages/pulp/webservices/controllers/repositories.py\", line 142, in DELETE\n    api.delete(id=id)\n  File \"/usr/lib/python2.6/site-packages/pulp/auditing.py\", line 195, in _audit\n    result = method(*args, **kwargs)\n  File \"/usr/lib/python2.6/site-packages/pulp/api/repo.py\", line 121, in delete\n    self.objectdb.remove(repo, safe=True)\n  File \"/usr/lib64/python2.6/site-packages/pymongo/collection.py\", line 379, in remove\n    message.delete(self.__full_name, spec, safe), safe)\n  File \"/usr/lib64/python2.6/site-packages/pymongo/message.py\", line 139, in delete\n    data += bson.BSON.from_dict(spec)\n  File \"/usr/lib64/python2.6/site-packages/pymongo/bson.py\", line 569, in from_dict\n    return cls(_dict_to_bson(dct, check_keys))\nInvalidDocument: document too large - BSON documents are limited to 4 MB\n"

Comment 1 Pradeep Kilambi 2010-08-17 14:43:36 UTC

*** This bug has been marked as a duplicate of bug 620495 ***


Note You need to log in before you can comment on or make changes to this bug.