Bug 62137 - Compile stops on "if ((!CONFIG_PCI)..."
Compile stops on "if ((!CONFIG_PCI)..."
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-27 15:16 EST by jm999
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-03 17:34:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jm999 2002-03-27 15:16:25 EST
?a?,zilla Helper:

User-Agent: Mozilla/4.0 (compatible; MSIE 5.13; Mac_PowerPC)



Description of problem:

The file drivers/net/e1000_main.c should have:

#ifdef CONFIG_PCI
    if (!pci_present())
#endif
        return (0);

because when CONFIG_PCI is not defined, the following in fails:

    if ((!CONFIG_PCI) || (!pci_present()))
        return (0);



Version-Release number of selected component (if applicable):





How reproducible:

Always



Steps to Reproduce:

1. Configure kernel with no PCI

2. Compile

3.

	



Actual Results:  Compile stops (trust me)



Expected Results:  compile to suceed



Additional info:
Comment 1 Pete Zaitcev 2002-06-03 15:11:13 EDT
So? Remove the e1000 from .config and re-run "make oldconfig".
Problem solved. Really, we have thousans of such things
coming from upstream.
Comment 2 Pete Zaitcev 2002-06-03 17:34:41 EDT
I think we never shipped e1000 with 6.2 (2.2 kernel).
Is the release set right?

Note You need to log in before you can comment on or make changes to this bug.