Bug 621376 - [abrt] fedora-packager-0.5.1.0-1.fc14: xmlrpclib.py:1294:single_request:AttributeError: PlgHTTPS instance has no attribute 'getresponse'
[abrt] fedora-packager-0.5.1.0-1.fc14: xmlrpclib.py:1294:single_request:Attri...
Status: CLOSED DUPLICATE of bug 619276
Product: Fedora
Classification: Fedora
Component: fedora-packager (Show other bugs)
14
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Dennis Gilmore
Fedora Extras Quality Assurance
abrt_hash:347d9355
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-04 17:26 EDT by Andreas Bierfert
Modified: 2013-01-10 01:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-06 15:28:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.75 KB, text/plain)
2010-08-04 17:26 EDT, Andreas Bierfert
no flags Details

  None (edit)
Description Andreas Bierfert 2010-08-04 17:26:55 EDT
abrt version: 1.1.10
architecture: x86_64
cmdline: /usr/bin/python /usr/bin/fedpkg scratch-build --srpm wine-1.3.0-1.fc15.src.rpm
comment: fedora-packager-0.5.1.0-1.fc14.noarch
component: fedora-packager
executable: /usr/bin/fedpkg
kernel: 2.6.35-0.57.rc6.git1.fc14.x86_64
package: fedora-packager-0.5.1.0-1.fc14
reason: xmlrpclib.py:1294:single_request:AttributeError: PlgHTTPS instance has no attribute 'getresponse'
release: Fedora release 14 (Branched)
time: 1280957097
uid: 500

backtrace
-----
xmlrpclib.py:1294:single_request:AttributeError: PlgHTTPS instance has no attribute 'getresponse'

Traceback (most recent call last):
  File "/usr/bin/fedpkg", line 959, in <module>
    args.command(args)
  File "/usr/bin/fedpkg", line 573, in scratchbuild
    build(args)
  File "/usr/bin/fedpkg", line 297, in build
    mymodule.init_koji(args.user, kojiconfig)
  File "/usr/lib/python2.7/site-packages/pyfedpkg/__init__.py", line 1102, in init_koji
    defaults['serverca'])
  File "/usr/lib/python2.7/site-packages/koji/__init__.py", line 1628, in ssl_login
    sinfo = self.callMethod('sslLogin', proxyuser)
  File "/usr/lib/python2.7/site-packages/koji/__init__.py", line 1673, in callMethod
    return self._callMethod(name, args, opts)
  File "/usr/lib/python2.7/site-packages/koji/__init__.py", line 1698, in _callMethod
    return proxy.__getattr__(name)(*args)
  File "/usr/lib64/python2.7/xmlrpclib.py", line 1224, in __call__
    return self.__send(self.__name, args)
  File "/usr/lib64/python2.7/xmlrpclib.py", line 1570, in __request
    verbose=self.__verbose
  File "/usr/lib64/python2.7/xmlrpclib.py", line 1264, in request
    return self.single_request(host, handler, request_body, verbose)
  File "/usr/lib64/python2.7/xmlrpclib.py", line 1294, in single_request
    response = h.getresponse(buffering=True)
AttributeError: PlgHTTPS instance has no attribute 'getresponse'

Local variables in innermost frame:
verbose: 0
request_body: "<?xml version='1.0'?>\n<methodCall>\n<methodName>sslLogin</methodName>\n<params>\n<param>\n<value><nil/></value></param>\n</params>\n</methodCall>\n"
h: <koji.ssl.SSLCommon.PlgHTTPS instance at 0x1ec9b00>
self: <koji.ssl.XMLRPCServerProxy.PlgSSL_Transport instance at 0x1ec9bd8>
host: 'koji.fedoraproject.org'
handler: '/kojihub/ssllogin'

How to reproduce
-----
fedpkg scratch-build --srpm wine-1.3.0-1.fc15.src.rpm
Comment 1 Andreas Bierfert 2010-08-04 17:26:57 EDT
Created attachment 436673 [details]
File: backtrace
Comment 2 Jesse Keating 2010-08-06 15:28:02 EDT

*** This bug has been marked as a duplicate of bug 619276 ***

Note You need to log in before you can comment on or make changes to this bug.