This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 62139 - 0.9.9-2 gets "hung up" on certain pages w/junkbuster
0.9.9-2 gets "hung up" on certain pages w/junkbuster
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: mozilla (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Blizzard
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-27 15:44 EST by Joe Harrington
Modified: 2007-04-18 12:41 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-04 12:09:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joe Harrington 2002-03-27 15:44:43 EST
Description of Problem:
I am using junkbuster with mozilla-0.9.9-2.  I am not certain whether this is a
junkbuster or a mozilla problem, but it does not happen with mozilla versions
prior to that released with Red Hat 7.2 (mozilla-0.9.2.1-2) nor on Netscape
Navigator.  Please reassign if it's a junkbuster problem.

After visiting pricewatch.com or a number of other pages, mozilla usually won't
visit certain other pages, even in another window that was already open before
visiting one of the problem pages.  Other pages it visits fine.  All works fine
without junkbuster.  Disconnecting and reconnecting the proxy fixes it until the
next visit to the bad pages.  I suspect something in the communication between
mozilla and junkbuster is messing up, and it gets cleared when the connection is
broken and a new one is generated.

Version-Release number of selected component (if applicable):
0.9.9-2

How Reproducible:
almost always

Steps to Reproduce:
1. set preferences to use junkbuster
2. visit pricewatch.com
3. visit http://adsabs.harvard.edu/abstract_service.html

Actual Results:
Browser stays on pricewatch.com or stays on pricewatch.com but displays the URL
for ADS or gives a junkbuster 404 page.

Expected Results:
Browser goes to http://adsabs.harvard.edu/abstract_service.html

Additional Information:
Beware of cached pages when testing this.  I am using junkbuster-2.0.2-28 with 

   4 -rw-r--r--    1 root     root         2331 Mar  1 04:42 imagelist
  24 -rw-r--r--    1 root     root        24168 Mar 24 04:22 blocklist

...and no cookiefile.  The imagelist and blocklist are the standard ones that
junkbuster distributes.  adsabs.harvard.edu is not blocked by junkbuster until
after a visit to one of the problem pages.

On several occasions, access to *all* sites was impossible.

I suspect that something about mozilla's communication with the proxy is messing
the proxy up, after which it behaves weirdly on all future connections from the
browser.  Disconnecting the channel and reconnecting it sets things aright,
until next time.

--jh--
Comment 1 Benny Amorsen 2002-04-04 12:09:16 EST
Setting the protocol version to HTTP/1.0 and disabling proxy keepalives fixes it
for me. I had the problem with galeon-1.2.0-5 and mozilla-0.9.9-4. Going to
http://news.google.com and then clicking a link going to Nando Times would
reproduce the problem more than 75% of the time when protocol version is set to
HTTP/1.1, but I cannot reproduce it with protocol version set to HTTP/1.0.

See http://bugzilla.mozilla.org/show_bug.cgi?id=135116
Comment 2 Christopher Blizzard 2002-08-29 17:55:10 EDT
Please try 1.0.1 and let me know if it fixes it for you.

Note You need to log in before you can comment on or make changes to this bug.