Bug 62147 - automount fails to shutdown properly on reboot
automount fails to shutdown properly on reboot
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: autofs (Show other bugs)
skipjack-beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Brock Organ
:
Depends On:
Blocks: 61590
  Show dependency treegraph
 
Reported: 2002-03-27 16:52 EST by jmbastia
Modified: 2007-04-18 12:41 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-28 16:32:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jmbastia 2002-03-27 16:52:27 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020310

Description of problem:
When rebooting, the automounter dies a horrible death with messages such as:
  umount2: Device or resource busy
  umount: automount(pid863): not found
  umount: /home: Illegal seek
  umount2: Invalid argument
  umount: automount(pid888): not found
  umount: /local: not mounted

Similar messages appear for my other automount points.

However, /var/log/messages contains messages that would make it
seem like the automounter shut down cleanly, such as:
  autofs: automount -USR2 succeeded
  autofs: automount -TERM succeeded
  automount[888]: shutting down, path = /local


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Hit CTRL-ALT-DEL to reboot the computer
2. Watch the messages as services are shut down
3. When autofs is shut down, the above error messages are shown
	

Actual Results:  The error messages listed above are shown.

Expected Results:  autofs should have shut down cleanly.

Additional info:

Except for the unclean shutdown, the automounter seems to be working properly. 
It's mounting the automount points correctly.
Comment 1 Nalin Dahyabhai 2002-04-01 18:07:36 EST
This should be fixed in autofs-3.1.7-27, which is a bit nicer about shutting
down the automount daemon (though you'll still get spewage if a directory can't
be unmounted because it's busy).

Note You need to log in before you can comment on or make changes to this bug.