Bug 621471 - No warning screen popped up when partitioning without swap
Summary: No warning screen popped up when partitioning without swap
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 14
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: David Cantrell
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F14Blocker, F14FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2010-08-05 07:34 UTC by He Rui
Modified: 2010-08-17 05:37 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-08-17 05:37:34 UTC


Attachments (Terms of Use)
logs under /tmp/ (45.74 KB, application/x-gzip)
2010-08-09 06:45 UTC, He Rui
no flags Details

Description He Rui 2010-08-05 07:34:45 UTC
Description of problem:
Install F14-alpha-tc2 without swap partitioning, no warning screen is shown explaining that system performance may suffer without a swap partition

Version-Release number of selected component (if applicable):
anaconda14.14
F14-alpha-tc2

How reproducible:
100%

Expected results:
# Anaconda warns that system performance may suffer without a swap partition
# Anaconda allows the installation to complete successfully

Comment 1 James Laska 2010-08-06 15:24:52 UTC
Hurry, can you gather all the /tmp/*log files from this installation and include them in the report?  Thanks!

Comment 2 He Rui 2010-08-09 06:45:51 UTC
Created attachment 437527 [details]
logs under /tmp/

Thanks James. Pls see attachment.

Comment 3 James Laska 2010-08-09 14:31:22 UTC
Adding to F14 Final release blocker as this falls into the criteria [1]:

  The installer must be able to create and install to any workable 
  partition layout using any file system offered in a default 
  installer configuration, LVM, software, hardware or BIOS RAID, 
  or combination of the above 

[1] https://fedoraproject.org/wiki/Fedora_14_Final_Release_Criteria

Comment 4 Kamil Páral 2010-08-16 07:56:07 UTC
I installed F14 Alpha RC4 DVD x86_64, chose custom layout, created just a single partition for / (no swap, no other partition) and I received a warning about missing swap partition. Therefore I didn't reproduce this bug.

Comment 5 He Rui 2010-08-17 05:37:34 UTC
Ah, it happened when there's already one swap partition but I didn't use it. And if I remove all swap partitions, the warning window will pop up. So close it as not a bug. Sorry for the noise everyone.


Note You need to log in before you can comment on or make changes to this bug.