Bug 621471 - No warning screen popped up when partitioning without swap
No warning screen popped up when partitioning without swap
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F14Blocker/F14FinalBlocker
  Show dependency treegraph
 
Reported: 2010-08-05 03:34 EDT by He Rui
Modified: 2010-08-17 01:37 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-17 01:37:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
logs under /tmp/ (45.74 KB, application/x-gzip)
2010-08-09 02:45 EDT, He Rui
no flags Details

  None (edit)
Description He Rui 2010-08-05 03:34:45 EDT
Description of problem:
Install F14-alpha-tc2 without swap partitioning, no warning screen is shown explaining that system performance may suffer without a swap partition

Version-Release number of selected component (if applicable):
anaconda14.14
F14-alpha-tc2

How reproducible:
100%

Expected results:
# Anaconda warns that system performance may suffer without a swap partition
# Anaconda allows the installation to complete successfully
Comment 1 James Laska 2010-08-06 11:24:52 EDT
Hurry, can you gather all the /tmp/*log files from this installation and include them in the report?  Thanks!
Comment 2 He Rui 2010-08-09 02:45:51 EDT
Created attachment 437527 [details]
logs under /tmp/

Thanks James. Pls see attachment.
Comment 3 James Laska 2010-08-09 10:31:22 EDT
Adding to F14 Final release blocker as this falls into the criteria [1]:

  The installer must be able to create and install to any workable 
  partition layout using any file system offered in a default 
  installer configuration, LVM, software, hardware or BIOS RAID, 
  or combination of the above 

[1] https://fedoraproject.org/wiki/Fedora_14_Final_Release_Criteria
Comment 4 Kamil Páral 2010-08-16 03:56:07 EDT
I installed F14 Alpha RC4 DVD x86_64, chose custom layout, created just a single partition for / (no swap, no other partition) and I received a warning about missing swap partition. Therefore I didn't reproduce this bug.
Comment 5 He Rui 2010-08-17 01:37:34 EDT
Ah, it happened when there's already one swap partition but I didn't use it. And if I remove all swap partitions, the warning window will pop up. So close it as not a bug. Sorry for the noise everyone.

Note You need to log in before you can comment on or make changes to this bug.