Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 621493 - Disabled cobbler when broken KS distro - many ISEs
Disabled cobbler when broken KS distro - many ISEs
Status: CLOSED DEFERRED
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Other (Show other bugs)
540
All Linux
high Severity high
: ---
: ---
Assigned To: Grant Gainey
Red Hat Satellite QA List
:
Depends On:
Blocks: 462714
  Show dependency treegraph
 
Reported: 2010-08-05 05:38 EDT by Garik Khachikyan
Modified: 2015-01-04 16:57 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-04 09:24:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
cobbler traceback - broken KS distro (2.51 KB, text/plain)
2010-08-05 05:38 EDT, Garik Khachikyan
no flags Details

  None (edit)
Description Garik Khachikyan 2010-08-05 05:38:44 EDT
Created attachment 436789 [details]
cobbler traceback - broken KS distro

Description of problem:
Cobbler refuses to start/serve when there is "broken" KS distro available in the list (or: /var/lib/cobbler/config/distros.d)
The issue is that during it's service-start cobbler seems parses *.json files of the kickstart distros and analyzes them (like search for kernel distro files, etc.), and if there is, for some reason, not found the correct structure of the kernel, it throws an sys.out to the console and dies...
This kind of issue could happen when there is (in my case, for example) manually mounted an iso image, prepared the KS distro, and for some reason, when that mount point get lost, the next cobbler restart definitely will broke cobbler and many KS pages with it...

Version-Release number of selected component (if applicable):
cobbler-2.0.3.1-3.el5
spacewalk-java-1.1.41-1.el5
spacewalk-backend-1.1.42-1.el5

How reproducible:
always on broken KS distros

Steps to Reproduce:
1. Mount F13 iso to /tmp/F13-i386
2. Prepare a KS distro with a path to that mounted point
3. umount the directory
4. Restart SW
  
Actual results:
Terrible cobbler traceback in console, pages related KS not opening (500 ISE)

Expected results:
Just marking that distro-s to invalid, i assume, would be the best

Additional info:
Traceback email is attached.
Removing the "broken" distro file from /var/lib/cobbler/config/distros.d "fixes" the issue.

Note You need to log in before you can comment on or make changes to this bug.