Bug 621512 - "Base Channels" list contains the channels info twice - created Org.
Summary: "Base Channels" list contains the channels info twice - created Org.
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Other   
(Show other bugs)
Version: 540
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Michael Mráka
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 462714
TreeView+ depends on / blocked
 
Reported: 2010-08-05 10:35 UTC by Garik Khachikyan
Modified: 2015-01-04 21:57 UTC (History)
2 users (show)

Fixed In Version: spacewalk-java-1.2.39-35
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-11 12:52:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
channels list - activation key creating page (184.08 KB, image/png)
2010-08-05 10:35 UTC, Garik Khachikyan
no flags Details

Description Garik Khachikyan 2010-08-05 10:35:12 UTC
Created attachment 436800 [details]
channels list - activation key creating page

Description of problem:
For the another org. created (and added the base Org. in the Trusts list) preparation of activation key lists the available base channels list twice.
Refer to the attachment.

Version-Release number of selected component (if applicable):
spacewalk-html-1.1.6-1.el5
spacewalk-java-1.1.35-1.el5
spacewalk-schema-1.1.19-1.el5
spacewalk-oracle-1.1.6-1.el5

How reproducible:
always on child organizations (with trust enabled with the main Org)

Steps to Reproduce:
1. Prepare a child Org and add a trust with the basic Org (the one which user admin belongs to :)
2. login by the admin of that child org.
3. prepare activation key - list the dropdown menu "Base Channels:"
4. List of the base channels is listed 2 times

Actual results:
2 times listed channels

Expected results:
The list of base channels should be provided just once


Additional info:

Comment 3 Michael Mráka 2011-01-11 12:52:45 UTC
The issue is no more present in Satellite 5.4.0 / spacewalk-java-1.2.39-35.


Note You need to log in before you can comment on or make changes to this bug.