Bug 62154 - ftp Passive mode problem with change in default behavior
ftp Passive mode problem with change in default behavior
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: ftp (Show other bugs)
7.3
alpha Linux
medium Severity low
: ---
: ---
Assigned To: wdovlrrw
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-27 18:21 EST by john.goshdigian
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-27 18:21:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description john.goshdigian 2002-03-27 18:21:24 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux alpha; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
In 7.2, it appears that the default behaoir for passive mode has been 
changed -  Passive mode is set by default.
When initiating ftp from a 7.2 system thru a port on a gateway, (runing older
versions of RH linux), the user logs in ok, but then
can not do much on the system - ls, mget, mput..
because the passive mode established a port that's not used on the proxy/gateway.

Example:
Name (proxy_gateway_name.domain): user@ftpservername.domain
331 Password required for user.
Password:
230 User user logged in.
Remote system type is UNIX.
Using binary mode to transfer files.
ftp> ls
227 Entering Passive Mode (192,58,206,40,215,229)
ftp: connect: No route to host
ftp>

Suggest: either change ftp default behavoir to be passive off (as it was in
previous versions) - or supply a release note to warn user of the changed
default in 7.2.

Note: this may be related to bugzilla # 58281

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.see description above
2.
3.
	

Additional info:
Comment 1 Phil Copeland 2002-04-30 22:36:55 EDT
In release note

Phil
=--=

Note You need to log in before you can comment on or make changes to this bug.