Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 621547 - RFE: Provide hotkey for temporary boot device selection
RFE: Provide hotkey for temporary boot device selection
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-05 09:11 EDT by Kamil Páral
Modified: 2011-05-05 03:43 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-05 03:43:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
example config dialog (62.34 KB, image/png)
2010-08-05 09:11 EDT, Kamil Páral
no flags Details

  None (edit)
Description Kamil Páral 2010-08-05 09:11:31 EDT
Created attachment 436838 [details]
example config dialog

Description of problem:
In an older libvirt release (I believe in Fedora 12) there used to be a hotkey (F12 key?) that could be pressed for temporary boot device selection, right after virtual machine start. Now in Fedora 13 this hotkey is no longer available.

It would be very nice if the hotkey option is added again to libvirt, maybe just as an optional feature, that can be enabled in preferences. Because currently if you need to boot from other than your default boot device for just one shot, you need to open config dialog, click click click (and 10 more clicks), apply (see screenshot). Boot, and then revert everything back to original state. That's very inconvenient.

Version-Release number of selected component (if applicable):
python-virtinst-0.500.3-4.fc13.noarch
virt-manager-0.8.4-2.fc13.noarch
libvirt-0.8.2-1.fc13.x86_64
virt-viewer-0.2.1-1.fc13.x86_64
libvirt-python-0.8.2-1.fc13.x86_64
libvirt-client-0.8.2-1.fc13.x86_64
virt-top-1.0.4-3.fc13.x86_64
Comment 1 Daniel Berrange 2010-09-10 12:39:05 EDT
I think this could be done much better in virt-manager, in no extra mouse clicks compared to starting normally, and without adding a hotkey back which was hard to press quickly enough at boot.

eg, the toolbar button for 'start' could be turned into a menu button. Pressing the button does a normal start, but it has drop down menu that has 

Start
 -> Boot network
 -> Boot floppy
 -> Boot cdrom


If no media is loaded in the floppy/cdrom, it could automatically popup a filechooser dialog box too.
Comment 2 Kamil Páral 2011-05-05 03:43:54 EDT
In virt-manager-0.8.7-2.fc14.noarch I see now checkbox "Enable boot menu" in Boot options. Marking as solved.

Note You need to log in before you can comment on or make changes to this bug.