Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 621557 - error while unregistering clients subscribed to RH-Personal
error while unregistering clients subscribed to RH-Personal
Status: CLOSED DUPLICATE of bug 624063
Product: Candlepin
Classification: Community
Component: candlepin (Show other bugs)
0.5
All Linux
high Severity high
: ---
: ---
Assigned To: Devan Goodwin
wes hayutin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-05 09:26 EDT by wes hayutin
Modified: 2015-05-14 11:22 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-31 14:31:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
snip of catalina.out (24.42 KB, text/plain)
2010-08-09 11:19 EDT, wes hayutin
no flags Details

  None (edit)
Description wes hayutin 2010-08-05 09:26:15 EDT
[root@client02-rhel6-beta2 src]# ./subscription-manager-cli unregister
Runtime Error javax.script.ScriptException: sun.org.mozilla.javascript.internal.WrappedException: Wrapped org.fedoraproject.candlepin.exceptions.ForbiddenException (<Unknown source>#140) in <Unknown source> at line number 140 at com.sun.script.javascript.RhinoScriptEngine.invoke:184


rhsm.log


2010-08-05 21:25:43,237 [INFO] __init__() @connection.py:128 - Value 'candlepin_ca_file' not present in config file. Assuming default value: /etc/pki/CA/candlepin.pem
2010-08-05 21:25:43,240 [INFO] __init__() @connection.py:133 - Connection Established: host: candlepin1.devlab.phx1.redhat.com, port: 443, handler: /candlepin
2010-08-05 21:25:43,241 [INFO] _request() @connection.py:61 - loading ca_file located at: /etc/pki/CA/candlepin.pem
2010-08-05 21:25:43,241 [INFO] _request() @connection.py:63 - work in insecure mode ?:True
2010-08-05 21:25:54,484 [INFO] _request() @connection.py:79 - response:{"displayMessage":"Runtime Error javax.script.ScriptException: sun.org.mozilla.javascript.internal.WrappedException: Wrapped org.fedoraproject.candlepin.exceptions.ForbiddenException (<Unknown source>#140) in <Unknown source> at line number 140 at com.sun.script.javascript.RhinoScriptEngine.invoke:184"}
2010-08-05 21:25:54,485 [INFO] _request() @connection.py:80 - status code: 500
2010-08-05 21:25:54,486 [ERROR] _do_command() @managercli.py:262 - Runtime Error javax.script.ScriptException: sun.org.mozilla.javascript.internal.WrappedException: Wrapped org.fedoraproject.candlepin.exceptions.ForbiddenException (<Unknown source>#140) in <Unknown source> at line number 140 at com.sun.script.javascript.RhinoScriptEngine.invoke:184
Traceback (most recent call last):
  File "/root/subscription-manager/src/managercli.py", line 256, in _do_command
    self.cp.unregisterConsumer(consumer)
  File "/root/subscription-manager/src/connection.py", line 196, in unregisterConsumer
    return self.conn.request_delete(method)
  File "/root/subscription-manager/src/connection.py", line 105, in request_delete
    return self._request("DELETE", method)
  File "/root/subscription-manager/src/connection.py", line 81, in _request
    self.validateResponse(result)
  File "/root/subscription-manager/src/connection.py", line 90, in validateResponse
    parsed['displayMessage'])
RestlibException: Runtime Error javax.script.ScriptException: sun.org.mozilla.javascript.internal.WrappedException: Wrapped org.fedoraproject.candlepin.exceptions.ForbiddenException (<Unknown source>#140) in <Unknown source> at line number 140 at com.sun.script.javascript.RhinoScriptEngine.invoke:184
2010-08-05 21:25:54,489 [ERROR] _do_command() @managercli.py:263 - Error: Unable to UnRegister the system: Runtime Error javax.script.ScriptException: sun.org.mozilla.javascript.internal.WrappedException: Wrapped org.fedoraproject.candlepin.exceptions.ForbiddenException (<Unknown source>#140) in <Unknown source> at line number 140 at com.sun.script.javascript.RhinoScriptEngine.invoke:184
2010-08-05 21:26:42,675 [INFO] __init__() @connection.py:111 - Connection Established: host: candlepin1.devlab.phx1.redhat.com, port: 443, handler: /candlepin
[root@client02-rhel6-beta2 src]#
Comment 1 wes hayutin 2010-08-05 09:28:17 EDT
recreate:
1. walk through the RH-Personal scenario using two clients
 a. on client1 walk through the steps that require to subscribe steps
 b. on client2 walk through the steps after the rh-personal pool has been initialized..

example:
[root@client02-rhel6-beta2 src]# ./subscription-manager-cli register --username=test2 --pass=redhat
063f2db0-af1b-4a48-a847-17458dc5f4ca test2
[root@client02-rhel6-beta2 src]# ./subscription-manager-cli list --available
063f2db0-af1b-4a48-a847-17458dc5f4ca
+-------------------------------------------+
    Available Subscriptions
+-------------------------------------------+


ProductName:       	RHEL for Physical Servers
ProductId:         	RH01                     
PoolId:            	631                      
Quantity:          	unlimited                
Expires:           	2011-07-20               

[root@client02-rhel6-beta2 src]# ./subscription-manager-cli unregister

*********************************************

will try w/ other accounts w/o rh-personal to see if its a more general issue
Comment 2 wes hayutin 2010-08-05 09:29:52 EDT
seems to be related to rh-personal
Comment 3 wes hayutin 2010-08-09 11:18:37 EDT
This looks like a candlepin issue, not an IT issue.

Recreated..

[root@client02-rhel6-beta2 src]# ./subscription-manager-cli unregister
Runtime Error javax.script.ScriptException: sun.org.mozilla.javascript.WrappedException: Wrapped org.fedoraproject.candlepin.exceptions.ForbiddenException (<Unknown source>#143) in <Unknown source> at line number 143 at com.sun.script.javascript.RhinoScriptEngine.invoke:209
Comment 4 wes hayutin 2010-08-09 11:19:00 EDT
Created attachment 437621 [details]
snip of catalina.out
Comment 5 Devan Goodwin 2010-08-31 14:31:31 EDT

*** This bug has been marked as a duplicate of bug 624063 ***

Note You need to log in before you can comment on or make changes to this bug.