Bug 621562 - Initscripts do not conform to LSB specification
Initscripts do not conform to LSB specification
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: nfs-utils (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Steve Dickson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-05 09:33 EDT by Kamil Páral
Modified: 2010-10-27 18:32 EDT (History)
2 users (show)

See Also:
Fixed In Version: nfs-utils-1.2.2-6.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-27 18:32:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kamil Páral 2010-08-05 09:33:23 EDT
Description of problem:
Initscripts rpcgssd and rpcsvcgssd do not conform to the LSB requirements. When I run:
$ service rpcgssd <anything>
I get no output and return code 6.

I believe it's caused by these lines:

# See if we are configured to start
[ "${SECURE_NFS}" != "yes" ] && exit 6

But that's not the point. Initscript should *always* return usage line on "service <service> usage" and *always* return their status on "service <service> status". These actions should never fail.

They can fail on other actions, but they should fail with reasonable error message at least.

From what I've seen this problem applies to rpcgssd and rpcsvcgssd initscripts.

Version-Release number of selected component (if applicable):
nfs-utils-1.2.2-2.fc13.x86_64

How reproducible:
always

Steps to Reproduce:
1. Have ${SECURE_NFS} to false
2. service rpcgssd usage (status, whatever)

Actual results:
No output

Expected results:
LSB compliant output and return code

Additional info:
Description of initscripts' desired behaviour may be found e.g. here:
https://fedoraproject.org/wiki/Packaging/SysVInitScript
Comment 1 Jeff Layton 2010-08-05 09:43:13 EDT
I haven't looked, but it's likely that Fedora just needs the same patch as this one proposed for RHEL6:

https://bugzilla.redhat.com/show_bug.cgi?id=596095#c15
Comment 2 Fedora Update System 2010-10-15 18:47:22 EDT
nfs-utils-1.2.2-6.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/nfs-utils-1.2.2-6.fc13
Comment 3 Fedora Update System 2010-10-17 00:49:58 EDT
nfs-utils-1.2.2-6.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update nfs-utils'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/nfs-utils-1.2.2-6.fc13
Comment 4 Kamil Páral 2010-10-26 04:54:33 EDT
https://admin.fedoraproject.org/updates/nfs-utils-1.2.2-6.fc13 fixes this issue.
Comment 5 Fedora Update System 2010-10-27 18:32:06 EDT
nfs-utils-1.2.2-6.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.