Bug 621563 - RepoError: Error getting repository data for installed, repository not found
RepoError: Error getting repository data for installed, repository not found
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
13
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:2c88e878cbc3bc74d...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-05 09:40 EDT by luigi votta
Modified: 2010-08-06 07:48 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-05 16:43:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (703.86 KB, text/plain)
2010-08-05 09:40 EDT, luigi votta
no flags Details

  None (edit)
Description luigi votta 2010-08-05 09:40:11 EDT
The following was filed automatically by anaconda:
anaconda 13.42 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.6/site-packages/yum/repos.py", line 121, in getRepo
    'Error getting repository data for %s, repository not found' % (repoid)
  File "/usr/lib/anaconda/yuminstall.py", line 160, in callback
    repo = self.repos.getRepo(po.repoid)
RepoError: Error getting repository data for installed, repository not found
Comment 1 luigi votta 2010-08-05 09:40:18 EDT
Created attachment 436850 [details]
Attached traceback automatically from anaconda.
Comment 2 Chris Lumens 2010-08-05 09:46:28 EDT
That's not even a complete traceback - it's missing several frames.  What were you doing when this happened?
Comment 3 luigi votta 2010-08-05 10:24:40 EDT
Ok.

F14 is already installed.

With the F13 DVD, Anaconda crashed after downloading the list of (remaining) package to install (8 new packages e.g gNote that in the first install gave a dependency problem).  

I use F13 DVD as the new boot.iso gives an error with python2.7. (An IOErrror after downloading the install.img)



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 4 Chris Lumens 2010-08-05 16:43:07 EDT
You're using the F13 DVD to install F14 because of an error in the current F14 boot.iso?  That's not really a supported configuration.  I suggest waiting for a stable release of F14 to try these installs.
Comment 5 luigi votta 2010-08-06 07:48:22 EDT
Thank you for replay.

(Next time that i'll report a bug i'll be more descriptive.)
 
This was the situation:
1. F14 is successfully installed with F13 DVD.
2. Re-do the installation using the same disk layout, without formatting nothing (why? see P.S. below).
3. An exception occurs during the (apparent) download of the package list (but behind this others happens that arises the error: it tries to copy/replace a new local time/date settings in a configuration already existing).

I don't know if this is important or already resolved: perhaps the only one situation in which this error could occur is during an upgrade from f13 to f14. 
(At any rate this bug is closed: ok.)

Greetings

P.S. I tried to figure out what is/use the phyton debugger in Anaconda.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.