Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 621579 - Traceback on "rhn-search cleanindex"
Traceback on "rhn-search cleanindex"
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: Server (Show other bugs)
1.1
All Linux
high Severity high
: ---
: ---
Assigned To: Michael Mráka
Jan Hutař
:
Depends On:
Blocks: space12
  Show dependency treegraph
 
Reported: 2010-08-05 10:35 EDT by Garik Khachikyan
Modified: 2015-01-04 16:57 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-19 11:16:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Garik Khachikyan 2010-08-05 10:35:21 EDT
Description of problem:
Traceback thrown in the console while running /etc/init.d/rhn-search cleanindex
---
Stopping rhn-search...
Stopped rhn-search.
2010-08-05 16:29:27,266 [main] ERROR com.redhat.satellite.search.DeleteIndexes - Caught Exception: 
com.ibatis.common.jdbc.exception.NestedSQLException:   
--- The error occurred in com/redhat/satellite/search/db/errata.xml.  
--- The error occurred while executing mapped statement.  
--- Check the deleteLastErrata.  
--- Check the statement or the result map.  
--- Cause: java.sql.SQLException: No suitable driver found for search.connection.url
	at com.ibatis.sqlmap.engine.mapping.statement.GeneralStatement.executeUpdate(GeneralStatement.java:91)
	at com.ibatis.sqlmap.engine.impl.SqlMapExecutorDelegate.update(SqlMapExecutorDelegate.java:505)
	at com.ibatis.sqlmap.engine.impl.SqlMapExecutorDelegate.delete(SqlMapExecutorDelegate.java:528)
	at com.ibatis.sqlmap.engine.impl.SqlMapSessionImpl.delete(SqlMapSessionImpl.java:98)
	at com.redhat.satellite.search.db.WriteQuery.delete(WriteQuery.java:72)
	at com.redhat.satellite.search.DeleteIndexes.deleteQuery(DeleteIndexes.java:87)
	at com.redhat.satellite.search.DeleteIndexes.main(DeleteIndexes.java:118)
Caused by: java.sql.SQLException: No suitable driver found for search.connection.url
	at java.sql.DriverManager.getConnection(DriverManager.java:640)
	at java.sql.DriverManager.getConnection(DriverManager.java:200)
	at com.ibatis.common.jdbc.SimpleDataSource.popConnection(SimpleDataSource.java:580)
	at com.ibatis.common.jdbc.SimpleDataSource.getConnection(SimpleDataSource.java:222)
	at com.ibatis.sqlmap.engine.transaction.jdbc.JdbcTransaction.init(JdbcTransaction.java:48)
	at com.ibatis.sqlmap.engine.transaction.jdbc.JdbcTransaction.getConnection(JdbcTransaction.java:89)
	at com.ibatis.sqlmap.engine.mapping.statement.GeneralStatement.executeUpdate(GeneralStatement.java:78)
	... 6 more
Starting rhn-search...
---


Version-Release number of selected component (if applicable):
spacewalk-search-1.1.2-1.el5
spacewalk-java-1.1.35-1.el5
spacewalk-backend-1.1.42-1.el5
spacewalk-schema-1.1.19-1.el5
spacewalk-oracle-1.1.6-1.el5


How reproducible:
always with current SW 1.1 

Steps to Reproduce:
1. just run /etc/init.d/rhn-search cleanindex
2.
3.
  
Actual results:
trackeback

Expected results:
Indexes should be recreated, the "/rhn/errata/Search.do" should be serving without any complains like:
---
Index files missing from search-server. Assuming data exists in database, indexes can be regenerated by running: /etc/init.d/rhn-search cleanindex, then restart rhn-search

Additional info:
Comment 1 Michael Mráka 2010-08-13 08:39:56 EDT
Should be fixed by
commit c0848f39799794c28786aa07e27402027dd02949
    correct the path to oci
commit 1a00594f47f4d88ad80da73457386c21c6e3ef2b
    build ConnectionURL from db_* values in rhn.conf
commit babc0da8c8ebab16859f2cdca0461254c8b29fe7
    set java.library.path for search to be able to find oci library

Package spacewalk-search-1.1.5-1.
Comment 4 Jan Pazdziora 2010-11-19 11:16:45 EST
With Spacewalk 1.2 released, marking as CLOSED CURRENTRELEASE.

https://www.redhat.com/archives/spacewalk-list/2010-November/msg00111.html

Note You need to log in before you can comment on or make changes to this bug.