Bug 621596 - Gnome-power-manager will not start
Summary: Gnome-power-manager will not start
Status: CLOSED DUPLICATE of bug 608402
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-power-manager   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: F14Blocker, F14FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2010-08-05 15:16 UTC by W. Michael Petullo
Modified: 2010-08-24 21:38 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-24 21:38:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gnome-power-manager-2.31.6-backlight-is-None.patch (666 bytes, patch)
2010-08-23 17:16 UTC, Will Woods
no flags Details | Diff

Description W. Michael Petullo 2010-08-05 15:16:58 UTC
Description of problem:
Gnome-power-manager will not start after upgrading Fedora 13 to Rawhide using yum.

Version-Release number of selected component (if applicable):
gnome-power-manager-2.31.4-1.fc14.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. Upgrade from Fedora 13 to Rawhide using yum
2. Run gnome-power-manager
  
Actual results:
gnome-power-manager 
Gtk-Message: Failed to load module "gail-gnome": libgail-gnome.so: cannot open shared object file: No such file or directory

** (gnome-power-manager:2127): WARNING **: AT-SPI: Accessibility bus not found - Using session bus.

(gnome-power-manager:2127): GLib-GObject-WARNING **: gsignal.c:2275: signal `proxy-status' is invalid for instance `0x260d8f0'
The program 'gnome-power-manager' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAtom (invalid Atom parameter)'.
  (Details: serial 168 error_code 5 request_code 149 minor_code 15)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

Expected results:
Gnome-power-manager should run.

Additional info:
It seems that /usr/lib64/gtk-3.0/modules/libgail-gnome.so is missing. If a package that provides this exists, then it should be a dependency for gnome-power-manager.

Comment 1 Bruno Wolff III 2010-08-12 15:16:55 UTC
There is more to this than a missing library. I had an at-spi library missing message and installed a package to get it, but this still didn't seem to get it to work.

Comment 2 Adam Williamson 2010-08-20 18:10:43 UTC
yeah, the 'missing' library is irrelevant, I have that library so don't have that message, but I still have no g-p-m running after a normal boot, and trying to run it manually, i get the 5/149/15 X Window System error.

This blocks Fedora 14 final:

"All elements of the default panel configuration must be functional "

the battery icon is part of the default panel configuration, and if g-p-m ain't working, that icon ain't working.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 3 Adam Williamson 2010-08-20 18:11:32 UTC
Adding mclasen to CC - he's been overseeing the big GNOME changes, and I believe hughsie is on vacation.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 4 Matthias Clasen 2010-08-20 23:35:48 UTC
Try the latest build, gnome-power-manager-2.31.6-3.fc14.x86_64 ?

Also, is upowerd running ?

Comment 5 Adam Williamson 2010-08-20 23:59:49 UTC
I tried gnome-power-manager-2.31.90-1.fc14 , no good. and yes, upowerd is running.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 6 Matthias Clasen 2010-08-23 16:24:59 UTC
Well, it's working fine here. 

Can you please do what GTK+ asked you:

The program 'gnome-power-manager' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAtom (invalid Atom parameter)'.
  (Details: serial 168 error_code 5 request_code 149 minor_code 15)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

and post the results here ?

Comment 7 Matthias Clasen 2010-08-23 16:25:58 UTC
Could be this issue: https://bugzilla.gnome.org/show_bug.cgi?id=627711

Comment 8 Will Woods 2010-08-23 17:16:42 UTC
Created attachment 440435 [details]
gnome-power-manager-2.31.6-backlight-is-None.patch

I was seeing this same problem - as far as I can tell, the problem is that the RandR brightness extension exists on my system, but brightness->priv->backlight gets set to None. So the extension is available but it doesn't know how to deal with my backlight.

When gpm starts up, it does gpm_brightness_output_get_internal, which attempts to do XRRGetOutputProperty on a property that is actually None, which causes the BadAtom error.

The attached patch will cause gpm_brightness_output_get_internal to properly return a failure if backlight is None.

Comment 9 Will Woods 2010-08-24 21:38:51 UTC

*** This bug has been marked as a duplicate of bug 608402 ***


Note You need to log in before you can comment on or make changes to this bug.