Bug 621696 - SELinux verhindert /usr/bin/perl "setattr" Zugriff on /var/cache/fontconfig.
SELinux verhindert /usr/bin/perl "setattr" Zugriff on /var/cache/fontconfig.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
12
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:eedb73ce308...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-05 16:39 EDT by Till Maas
Modified: 2010-08-10 17:41 EDT (History)
3 users (show)

See Also:
Fixed In Version: selinux-policy-3.7.19-44.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-10 17:41:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Till Maas 2010-08-05 16:39:21 EDT
Zusammenfassung:

SELinux verhindert /usr/bin/perl "setattr" Zugriff on /var/cache/fontconfig.

Detaillierte Beschreibung:

[SELinux ist in freizügigem Modus. Dieser Zugriff wurde nicht verweigert.]

SELinux verweigerte den von munin-graph angeforderten Zugriff. Da nicht davon
ausgegangen wird, dass dieser Zugriff von munin-graph benötigt wird,
signalisiert dies möglicherweise einen Einbruchsversuch. Es ist ausserdem
möglich, dass diese spezielle Version oder Konfiguration der Anwendung den
zusätzlichen Zugriff verursacht.

Zugriff erlauben:

Sie können ein lokales Richtlininenmodul generieren, um diesen Zugriff zu
erlauben siehe FAQ (http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385)
Bitte reichen Sie einen Fehlerbericht ein.

Zusätzliche Informationen:

Quellkontext                  system_u:system_r:munin_t:s0-s0:c0.c1023
Zielkontext                   system_u:object_r:fonts_cache_t:s0
Zielobjekte                   /var/cache/fontconfig [ dir ]
Quelle                        munin-graph
Quellpfad                     /usr/bin/perl
Port                          <Unbekannt>
Host                          (entfernt)
RPM-Pakete der Quelle         perl-5.10.0-90.fc12
RPM-Pakete des Ziels          fontconfig-2.8.0-1.fc12
Richtlinien-RPM               selinux-policy-3.6.32-118.fc12
SELinux aktiviert             True
Richtlinientyp                targeted
Enforcing-Modus               Permissive
Plugin-Name                   catchall
Rechnername                   (entfernt)
Plattform                     Linux (entfernt)
                              2.6.32.16-150.fc12.x86_64 #1 SMP Sat Jul 24
                              05:19:12 UTC 2010 x86_64 x86_64
Anzahl der Alarme             3
Zuerst gesehen                Di 13 Jul 2010 21:40:18 CEST
Zuletzt gesehen               Do 05 Aug 2010 13:30:18 CEST
Lokale ID                     8f6b09f7-b742-411b-a252-d70422167f4a
Zeilennummern                 

Raw-Audit-Meldungen           

node=(entfernt) type=AVC msg=audit(1281007818.225:58110): avc:  denied  { setattr } for  pid=15669 comm="munin-graph" name="fontconfig" dev=dm-10 ino=11331 scontext=system_u:system_r:munin_t:s0-s0:c0.c1023 tcontext=system_u:object_r:fonts_cache_t:s0 tclass=dir

node=(entfernt) type=SYSCALL msg=audit(1281007818.225:58110): arch=c000003e syscall=90 success=no exit=-1 a0=2193880 a1=1ed a2=d a3=7fff1c9c3150 items=0 ppid=15667 pid=15669 auid=487 uid=487 gid=470 euid=487 suid=487 fsuid=487 egid=470 sgid=470 fsgid=470 tty=(none) ses=116 comm="munin-graph" exe="/usr/bin/perl" subj=system_u:system_r:munin_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,munin-graph,munin_t,fonts_cache_t,dir,setattr
audit2allow suggests:

#============= munin_t ==============
allow munin_t fonts_cache_t:dir setattr;
Comment 1 Daniel Walsh 2010-08-05 16:46:05 EDT
Miroslav add

miscfiles_setattr_fonts_cache_dirs(munin_t)
Comment 2 Miroslav Grepl 2010-08-06 06:55:06 EDT
Fixed in selinux-policy-3.7.19-44.fc13.noarch
Comment 3 Fedora Update System 2010-08-06 09:41:25 EDT
selinux-policy-3.7.19-44.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/selinux-policy-3.7.19-44.fc13
Comment 4 Fedora Update System 2010-08-06 16:59:58 EDT
selinux-policy-3.7.19-44.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update selinux-policy'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/selinux-policy-3.7.19-44.fc13
Comment 5 Till Maas 2010-08-06 17:10:25 EDT
Just to make sure this is not missed, because there is only a Fedora 13 update: I reported the bug for Fedora 12.
Comment 6 Miroslav Grepl 2010-08-09 08:07:16 EDT
Thanks. I will add it to F12.
Comment 7 Fedora Update System 2010-08-10 17:39:50 EDT
selinux-policy-3.7.19-44.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.