Bug 62170 - [RFE] up2date should reconnect on dialup reconnects
[RFE] up2date should reconnect on dialup reconnects
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-27 23:28 EST by Rich Birch
Modified: 2015-01-07 18:55 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-06 18:18:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rich Birch 2002-03-27 23:28:25 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
I connect to the internet via a 56k modem, and my ISP disconnects me every 2
hours. When I do get disconnected, up2date fails to carry on, once reconnected,
if it was downloading an rpm. Also, it doesn't seem to attempt to send anything
to the internet because my server doesn't automatically reconnect (it's setup to
dial when it detects an attempt to access the internet).
 
Out of curiosity I tried just disconnecting my computer from the server that
provides internet access to see if the same thing happened but, upon
reconnecting, up2date carried on. This lead me to believe that up2date simply
waits for the data to be sent to it, and because when i re-dial i get a
different IP address, up2date never receives anything.

Is this correct, and is there any chance of the behaviour being modified? It
would be much more useful to me if it could handle my being disconnected from
the net every so often.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. get up2date to start downloading
2. cut off the dial-up internet connection
3. reconnect, and observe up2date not carrying on

Actual Results:  up2date hangs

Expected Results:  up2date should send another request for the rpm after a
timeout period

Additional info:

Another annoying thing i've noticed is that if up2date has already downloaded
part of an rpm, it will start the download from scratch if it's restarted,
rather than resuming. I'm not sure if this can be considered a bug.

Note You need to log in before you can comment on or make changes to this bug.