Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 621711 - Update pulls in i686 packages on x86_64
Update pulls in i686 packages on x86_64
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: perl (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Petr Pisar
Fedora Extras Quality Assurance
:
: 661351 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-05 17:52 EDT by David Zeuthen
Modified: 2013-03-05 23:04 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-10 13:14:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
failling yum upgrade log (4.59 KB, text/plain)
2010-11-30 10:50 EST, Petr Pisar
no flags Details

  None (edit)
Description David Zeuthen 2010-08-05 17:52:36 EDT
I'm on Fedora 13, x86_64 with no i686 packages. Latest update wants to pull them in though. Same result with updates-testing enabled, FWIW.

# yum update
Loaded plugins: auto-update-debuginfo, presto, refresh-packagekit
Found 6 installed debuginfo package(s)
Enabling fedora-debuginfo: Fedora 13 - x86_64 - Debug
Enabling updates-debuginfo: Fedora 13 - x86_64 - Updates - Debug
google-chrome                                            |  951 B     00:00     
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package gnupg2.x86_64 0:2.0.14-4.fc13 set to be updated
---> Package kernel.x86_64 0:2.6.33.6-147.2.4.fc13 set to be installed
---> Package kernel-headers.x86_64 0:2.6.33.6-147.2.4.fc13 set to be updated
---> Package paps.x86_64 0:0.6.8-14.fc13 set to be updated
---> Package paps-libs.x86_64 0:0.6.8-14.fc13 set to be updated
---> Package perf.noarch 0:2.6.33.6-147.2.4.fc13 set to be updated
--> Processing Dependency: perl = 4:5.10.1-112.fc13 for package: 3:perl-version-0.80-112.fc13.x86_64
---> Package perl.x86_64 4:5.10.1-116.fc13 set to be updated
---> Package perl-Module-Pluggable.x86_64 1:3.90-116.fc13 set to be updated
---> Package perl-Pod-Escapes.x86_64 1:1.04-116.fc13 set to be updated
---> Package perl-Pod-Simple.x86_64 1:3.07-116.fc13 set to be updated
--> Processing Dependency: perl-libs = 4:5.10.1-112.fc13 for package: 4:perl-5.10.1-112.fc13.i686
---> Package perl-libs.x86_64 4:5.10.1-116.fc13 set to be updated
---> Package usbmuxd.x86_64 0:1.0.5-1.fc13 set to be updated
--> Running transaction check
---> Package perl.i686 4:5.10.1-112.fc13 set to be updated
--> Processing Dependency: libm.so.6 for package: 4:perl-5.10.1-112.fc13.i686
--> Processing Dependency: libutil.so.1 for package: 4:perl-5.10.1-112.fc13.i686
--> Processing Dependency: libcrypt.so.1 for package: 4:perl-5.10.1-112.fc13.i686
--> Processing Dependency: libc.so.6(GLIBC_2.3.2) for package: 4:perl-5.10.1-112.fc13.i686
--> Processing Dependency: libdb-4.8.so for package: 4:perl-5.10.1-112.fc13.i686
--> Processing Dependency: libc.so.6(GLIBC_2.1) for package: 4:perl-5.10.1-112.fc13.i686
--> Processing Dependency: libc.so.6(GLIBC_2.1.3) for package: 4:perl-5.10.1-112.fc13.i686
--> Processing Dependency: libc.so.6 for package: 4:perl-5.10.1-112.fc13.i686
--> Processing Dependency: libpthread.so.0(GLIBC_2.3.2) for package: 4:perl-5.10.1-112.fc13.i686
--> Processing Dependency: libc.so.6(GLIBC_2.2) for package: 4:perl-5.10.1-112.fc13.i686
--> Processing Dependency: libresolv.so.2 for package: 4:perl-5.10.1-112.fc13.i686
--> Processing Dependency: libpthread.so.0(GLIBC_2.1) for package: 4:perl-5.10.1-112.fc13.i686
--> Processing Dependency: libc.so.6(GLIBC_2.3) for package: 4:perl-5.10.1-112.fc13.i686
--> Processing Dependency: libc.so.6(GLIBC_2.3.4) for package: 4:perl-5.10.1-112.fc13.i686
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: 4:perl-5.10.1-112.fc13.i686
--> Processing Dependency: libm.so.6(GLIBC_2.0) for package: 4:perl-5.10.1-112.fc13.i686
--> Processing Dependency: libdl.so.2 for package: 4:perl-5.10.1-112.fc13.i686
--> Processing Dependency: libgdbm.so.2 for package: 4:perl-5.10.1-112.fc13.i686
--> Processing Dependency: libpthread.so.0(GLIBC_2.0) for package: 4:perl-5.10.1-112.fc13.i686
--> Processing Dependency: librt.so.1(GLIBC_2.2) for package: 4:perl-5.10.1-112.fc13.i686
--> Processing Dependency: librt.so.1 for package: 4:perl-5.10.1-112.fc13.i686
--> Processing Dependency: libc.so.6(GLIBC_2.11) for package: 4:perl-5.10.1-112.fc13.i686
--> Processing Dependency: libc.so.6(GLIBC_2.2.4) for package: 4:perl-5.10.1-112.fc13.i686
--> Processing Dependency: libnsl.so.1 for package: 4:perl-5.10.1-112.fc13.i686
--> Processing Dependency: libc.so.6(GLIBC_2.0) for package: 4:perl-5.10.1-112.fc13.i686
--> Processing Dependency: libpthread.so.0 for package: 4:perl-5.10.1-112.fc13.i686
---> Package perl-libs.i686 4:5.10.1-112.fc13 set to be updated
--> Running transaction check
---> Package db4.i686 0:4.8.30-1.fc13 set to be updated
---> Package gdbm.i686 0:1.8.0-33.fc12 set to be updated
---> Package glibc.i686 0:2.12-3 set to be updated
--> Processing Dependency: libfreebl3.so for package: glibc-2.12-3.i686
--> Processing Dependency: libfreebl3.so(NSSRAWHASH_3.12.3) for package: glibc-2.12-3.i686
--> Running transaction check
---> Package nss-softokn-freebl.i686 0:3.12.6-3.fc13 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package                  Arch      Version                    Repository  Size
================================================================================
Installing:
 kernel                   x86_64    2.6.33.6-147.2.4.fc13      updates     21 M
Updating:
 gnupg2                   x86_64    2.0.14-4.fc13              updates    1.6 M
 kernel-headers           x86_64    2.6.33.6-147.2.4.fc13      updates    768 k
 paps                     x86_64    0.6.8-14.fc13              updates     33 k
 paps-libs                x86_64    0.6.8-14.fc13              updates     24 k
 perf                     noarch    2.6.33.6-147.2.4.fc13      updates    101 k
 perl                     x86_64    4:5.10.1-116.fc13          updates     10 M
 perl-Module-Pluggable    x86_64    1:3.90-116.fc13            updates     35 k
 perl-Pod-Escapes         x86_64    1:1.04-116.fc13            updates     28 k
 perl-Pod-Simple          x86_64    1:3.07-116.fc13            updates    193 k
 perl-libs                x86_64    4:5.10.1-116.fc13          updates    575 k
 usbmuxd                  x86_64    1.0.5-1.fc13               updates     60 k
Installing for dependencies:
 db4                      i686      4.8.30-1.fc13              updates    614 k
 gdbm                     i686      1.8.0-33.fc12              fedora      27 k
 glibc                    i686      2.12-3                     updates    4.3 M
 nss-softokn-freebl       i686      3.12.6-3.fc13              updates    112 k
 perl                     i686      4:5.10.1-112.fc13          fedora     9.9 M
 perl-libs                i686      4:5.10.1-112.fc13          fedora     586 k

Transaction Summary
================================================================================
Install       7 Package(s)
Upgrade      11 Package(s)

Total download size: 50 M
Is this ok [y/N]:
Comment 1 Petr Pisar 2010-08-10 04:32:09 EDT
> --> Processing Dependency: perl = 4:5.10.1-112.fc13 for package:
> 3:perl-version-0.80-112.fc13.x86_64


For some reason, you have old perl-version package (current is perl-version-0.82-1.fc13.x86_64) that pulls old perl 112 release and because there is no such package in x86_64 however there is such in i686, yum wants to install perl-*112.i686:

# repoquery perl
perl-4:5.10.1-112.fc13.i686
perl-4:5.10.1-116.fc13.x86_64

The last question is why there so old perl-*.i686 in x86_64 repository: Answer is rel-engs have broken composition while mashing mirrors and have not fixed it yet. (See <https://fedorahosted.org/rel-eng/ticket/3695>. I contacted jkeating directly and he stated rel-engs did not have free time to solve it now.)

I recommend to you to figure out why your yum does not want to upgrade perl-version. Try `yum upgrade perl-version', then `yum install perl-version-0.82-1.fc13.x86_64' explicitly.
Comment 2 David Zeuthen 2010-08-10 13:11:44 EDT
Yes, for some reason I have two versions installed...

# rpm -q perl-version
perl-version-0.80-112.fc13.x86_64
perl-version-0.82-1.fc13.x86_64
Comment 3 David Zeuthen 2010-08-10 13:14:15 EDT
After nuking the dupes, the problem is gone. Closing as PEBCAK. Thanks :-)
Comment 4 Petr Pisar 2010-11-30 10:50:40 EST
Created attachment 463763 [details]
failling yum upgrade log

Just for future reference:

I tried to solve this issue by "Obsoletes: perl < 4:5.10.1-121" in perl package and removal of "Requires:       perl = %{perl_epoch}:%{perl_version}-%{release}" in perl-libs, however yum-3.2.28-5 with rpm-4.8.1-2 is not able to proceed upgrade from relatively solid state:

# rpm -q perl perl-libs
perl-5.10.1-112.fc13.x86_64
perl-5.10.1-112.fc13.i686
perl-libs-5.10.1-112.fc13.x86_64
perl-libs-5.10.1-112.fc13.i686

# yum check
Loaded plugins: presto, refresh-packagekit
check all

yum upgrade output is attached (due to line wrap), the perl-multiarch is repository with my testing builds.
Comment 5 Petr Pisar 2010-11-30 10:51:25 EST
(In reply to comment #4)
> Created attachment 463763 [details]
> failling yum upgrade log
> 
> Just for future reference:
> 
> I tried to solve this issue
without success.
Comment 6 Petr Pisar 2010-12-08 12:32:07 EST
*** Bug 661351 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.