Bug 621771 - Sound stutters during KDE logout
Sound stutters during KDE logout
Status: CLOSED DEFERRED
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Jaroslav Kysela
Ken Benoit
: RHELNAK
Depends On:
Blocks: 846704
  Show dependency treegraph
 
Reported: 2010-08-06 01:11 EDT by Terry Griffin
Modified: 2016-08-16 12:04 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-16 12:04:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Terry Griffin 2010-08-06 01:11:14 EDT
Description of problem:

When logging out from KDE the sound stutters as the logout notification is played (KDE-Sys-Log-Out.ogg).

Version-Release number of selected component (if applicable):
kernel-2.6.32-44.1.el6.x86_64
kdebase-runtime-4.3.4-9.el6.x86_64
kdemultimedia-4.3.4-3.el6.x86_64
kdelibs-4.3.4-10.el6.x86_64
kdemultimedia-libs-4.3.4-3.el6.x86_64

How reproducible:
90%

Steps to Reproduce:
1. Logout from KDE desktop
2.
3.
  
Actual results:
Logout notification is played with a stutter.

Expected results:
No stutter.

Additional info:

Audio device is an Intel 5 Series/3400 HD Audio.
Logout sound plays fine from the KDE System Notification configuration tool.
Login sound plays fine during KDE login.
Comment 2 RHEL Product and Program Management 2010-08-06 01:27:37 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 3 RHEL Product and Program Management 2010-08-18 17:25:25 EDT
Thank you for your bug report. This issue was evaluated for inclusion
in the current release of Red Hat Enterprise Linux. Unfortunately, we
are unable to address this request in the current release. Because we
are in the final stage of Red Hat Enterprise Linux 6 development, only
significant, release-blocking issues involving serious regressions and
data corruption can be considered.

If you believe this issue meets the release blocking criteria as
defined and communicated to you by your Red Hat Support representative,
please ask your representative to file this issue as a blocker for the
current release. Otherwise, ask that it be evaluated for inclusion in
the next minor release of Red Hat Enterprise Linux.
Comment 4 Kurt Bechstein 2011-03-12 14:04:07 EST
Can this bug now be addressed as it is definitely an issue with KDE and is an annoying one.  I agree it didn't need to block the release of RHEL 6, but now it should be addressed.
Comment 5 Kurt Bechstein 2011-03-14 23:26:51 EDT
Just an update on this one.  This seems to be pulseaudio related.  I can remove pulseaudio from the system and then sound starts behaving properly then.  I seem to remember having this issues in Fedora and it was resolved in later releases of Fedora so might be worth checking and see what was changed there.
Comment 6 Tomasz Kepczynski 2011-04-03 15:03:59 EDT
I've seen the same issue on Scientific Linux 6. However I do believe this is kslowd issue described in bug #655694 as applying workaround from https://bugzilla.redhat.com/show_bug.cgi?id=655694#c23 helped with the logout sound issue as well.
Could you tell us what GRAPHIC card you have?
Comment 7 Terry Griffin 2011-04-03 16:04:29 EDT
My lspci reports:

00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02)

Which is identical to the card reported in comment 24 of bug #655694.
Comment 8 Kurt Bechstein 2011-04-03 23:54:55 EDT
I have two machines where I'm seeing this issue.  I have a laptop with an Intel Graphics video chipset.  The lspci output for that machine is:
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (primary) (rev 0c).

The other machine has an Nvidia based graphics chip, but Intel audio as far as I know.  I'm not actually at that one right now, but I do know for certain it is Nvidia based as far as the graphics chip goes.

I went and checked out the bug #655694.  I tried adding the suggested kernel parameter and rebooted my laptop with the Intel graphics.  It did not help the logout issue at all.
Comment 9 RHEL Product and Program Management 2011-10-07 11:10:10 EDT
Since RHEL 6.2 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 11 Beth Uptagrafft 2016-08-16 12:04:30 EDT
This issue is extremely old.  If there is still a customer affected on the latest version of RHEL6, please reopen and provide specifics.

Note You need to log in before you can comment on or make changes to this bug.