Bug 621775 - kernel panic- not syncing: VFS : unable to mount root fs on unknown-block(9,2)
Summary: kernel panic- not syncing: VFS : unable to mount root fs on unknown-block(9,2)
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: 14
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: F14Alpha, F14AlphaBlocker
TreeView+ depends on / blocked
 
Reported: 2010-08-06 05:50 UTC by He Rui
Modified: 2010-08-09 12:58 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-09 12:58:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kernel panic screen (146.38 KB, image/png)
2010-08-06 05:50 UTC, He Rui
no flags Details
kernel log (17.95 KB, text/plain)
2010-08-06 12:50 UTC, Kamil Páral
no flags Details
Diff comparing initrd.img content from TC#2 and RC#1 (5.22 KB, patch)
2010-08-06 14:47 UTC, James Laska
no flags Details | Diff

Description He Rui 2010-08-06 05:50:03 UTC
Created attachment 437033 [details]
kernel panic screen

Description of problem:
Boot F14-alpha-rc1-x86_64-boot.iso, kernel panic before stage1.

Version-Release number of selected component (if applicable):
F14-alpha-rc1-x86_64-boot.iso

How reproducible:
100%

Steps to Reproduce:
1.Boot F14-alpha-rc1-x86_64-boot.iso

Additional info:
Platform i386 works fine.

Comment 1 Kamil Páral 2010-08-06 08:58:47 UTC
Confirmed on F14 Alpha RC1 DVD x86_64 image.

Comment 2 Chris Lumens 2010-08-06 12:29:46 UTC
Please attach the complete kernel log.  We have not changed anything in the image building process that I am aware of, so this is unlikely to be an anaconda problem.

Comment 3 Kamil Páral 2010-08-06 12:50:30 UTC
Created attachment 437136 [details]
kernel log

kernel log attached. tested in KVM.

Comment 4 James Laska 2010-08-06 14:47:08 UTC
Created attachment 437175 [details]
Diff comparing initrd.img content from TC#2 and RC#1

I looks like there is significant "stuff" missing from the initrd.img for RC#1.  Attaching a diff comparing the contents of the initrd.img between RC#1 and TC#2.

Comment 5 Paul W. Frields 2010-08-06 16:52:46 UTC
dgilmore is trying to identify the root cause of this issue, which seems to be related to the compose process.

Comment 6 Paul W. Frields 2010-08-06 17:07:49 UTC
By the way, the compose is being tracked by the rel-eng team here:
https://fedorahosted.org/rel-eng/ticket/3860

Comment 7 Andre Robatino 2010-08-07 11:34:00 UTC
I did a successful install from the RC2 x86_64 DVD.

Comment 8 He Rui 2010-08-09 05:13:13 UTC
Verified it fixed in F14-alpha-rc2-x86.64 images.

Comment 9 James Laska 2010-08-09 12:58:18 UTC
Closing based on feedback in comment#8 and comment#7.  Thanks gang!


Note You need to log in before you can comment on or make changes to this bug.