Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 621845 - Wrong installType value for Fedora releases - kickstart.tree.create
Wrong installType value for Fedora releases - kickstart.tree.create
Status: CLOSED DUPLICATE of bug 622702
Product: Spacewalk
Classification: Community
Component: API (Show other bugs)
1.2
All Linux
low Severity medium
: ---
: ---
Assigned To: Tomas Lestach
Red Hat Satellite QA List
:
Depends On:
Blocks: sat540-triage space12
  Show dependency treegraph
 
Reported: 2010-08-06 05:34 EDT by Garik Khachikyan
Modified: 2015-01-04 16:57 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-20 06:25:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Garik Khachikyan 2010-08-06 05:34:35 EDT
Description of problem:
In the specification of API section of kickstart.tree.create() XML/RPC call there is defined "fedora_9" as a value of installType for Fedora releases.
But actual implementation takes the value: "fedora".

Version-Release number of selected component (if applicable):
SW 1.1

How reproducible:
always

Steps to Reproduce:
1. call kickstart.tree.create (...args, installType='fedora_9') - it fails
2.
3.
  
Actual results:
Failure

Expected results:
API call should pass with a call of "fedora" (if documentation gets updated") or with a call of "fedora_9" - if there is devel. implementation would be changed.

Additional info:
Comment 3 Garik Khachikyan 2010-08-20 06:25:29 EDT

*** This bug has been marked as a duplicate of bug 622702 ***

Note You need to log in before you can comment on or make changes to this bug.