Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 621864 - MTA file conflicts found in F14-Alpha-RC1-i386-DVD
MTA file conflicts found in F14-Alpha-RC1-i386-DVD
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Bill Nottingham
:
Depends On:
Blocks: F14Alpha/F14AlphaBlocker
  Show dependency treegraph
 
Reported: 2010-08-06 06:32 EDT by He Rui
Modified: 2014-03-16 23:24 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-10 16:12:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
test case code fix (364 bytes, patch)
2010-08-09 12:38 EDT, François Cami
no flags Details | Diff

  None (edit)
Description He Rui 2010-08-06 06:32:07 EDT
Description of problem:

== File conflicts, listed by conflicting packages ==
2:postfix-2.7.1-1.fc14.i686
exim-4.71-4.fc14.i686
sendmail-8.14.4-9.fc14.i686
ssmtp-2.61-15.fc14.i686
  /usr/share/man/man1/mailq.1.gz

2:postfix-2.7.1-1.fc14.i686
sendmail-8.14.4-9.fc14.i686
ssmtp-2.61-15.fc14.i686
  /usr/share/man/man1/newaliases.1.gz
  /usr/share/man/man8/sendmail.8.gz
Comment 1 Miroslav Lichvar 2010-08-06 06:48:14 EDT
Hm, these are ghost files managed by alternatives, following guidelines:

http://fedoraproject.org/wiki/Packaging:Alternatives

Are the conflicts reported by rpm?
Comment 2 James Laska 2010-08-06 11:08:40 EDT
Miroslav: no, these are conflicts discovered while testing Fedora Alpha.  These file conflicts exist on the Fedora Alpha DVD and can be discovered by running the test case https://fedoraproject.org/wiki/QA:Testcase_Mediakit_FileConflicts

Is it possible our test case doesn't account for %ghost files properly?  Are these packages able to be installed at the same time?
Comment 3 François Cami 2010-08-06 18:56:04 EDT
I'm able to reproduce this on F14 Alpha RC1 x86_64, but not on F13 GA x86_64.
Comment 4 Jens Petersen 2010-08-08 08:53:17 EDT
Why/are we really shipping 4 MTAs on media?
Comment 5 François Cami 2010-08-08 14:20:17 EDT
> Are these packages able to be installed at the same time?

On my F14 test VM, the answer is yes.

# rpm -q sendmail postfix exim ssmtp
sendmail-8.14.4-9.fc14.x86_64
postfix-2.7.1-1.fc14.x86_64
exim-4.71-4.fc14.x86_64
ssmtp-2.61-15.fc14.x86_64

Please note that I haven't tried selecting them at install time yet.

--
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 6 François Cami 2010-08-09 12:37:08 EDT
(courtesy of skvidal)
as far as rpm is concerned, if any of two conflicting files is a ghost, they are both identical. Relevant code snippet:

int rpmfiCompare(const rpmfi afi, const rpmfi bfi)
{
  rpmFileTypes awhat = rpmfiWhatis(rpmfiFMode(afi));
  rpmFileTypes bwhat = rpmfiWhatis(rpmfiFMode(bfi));
  if ((rpmfiFFlags(afi) & RPMFILE_GHOST) ||
  (rpmfiFFlags(bfi) & RPMFILE_GHOST)) return 0;

So the test case code seems wrong. Attaching a patch (again courtesy of skvidal) to fix it.

--
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 7 François Cami 2010-08-09 12:38:37 EDT
Created attachment 437648 [details]
test case code fix
Comment 8 Bill Nottingham 2010-08-09 13:26:10 EDT
WRT comment #4, I believe that's a pungi artifact of pulling all providers of a particular dep.
Comment 9 He Rui 2010-08-10 07:57:25 EDT
(In reply to comment #7)
> Created an attachment (id=437648) [details]
> test case code fix    

The conflicts wasn't shown by using this code fix, so this is the test case script problem?
Comment 10 Bill Nottingham 2010-08-10 10:07:55 EDT
He, yes. The issue is that the test case is showing false positives.
Comment 11 James Laska 2010-08-10 16:12:13 EDT
Patch to correct the test case but out for review [1].  I expect this change will be accepted and made available shortly.  Closing this issue out as NOTABUG (which of course isn't entirely accurate).  Please file a ticket against autoqa [2] should this problem remain after the patch has been accepted.

[1] https://fedorahosted.org/pipermail/autoqa-devel/2010-August/000997.html
[2] https://fedorahosted.org/autoqa

Note You need to log in before you can comment on or make changes to this bug.