Bug 621875 - after update to 2.6.32.16-150 the ethernet doesnt work anymore
after update to 2.6.32.16-150 the ethernet doesnt work anymore
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
12
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-06 07:14 EDT by Jan Teichmann
Modified: 2010-08-08 05:37 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-08 05:37:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Teichmann 2010-08-06 07:14:53 EDT
Description of problem:
since the update to kernel 2.6.32.16-150.fc12 my eth0 interface doesn't work anymore.

ethtool eth0:
Settings for eth0:
	Supported ports: [ TP ]
	Supported link modes:   10baseT/Half 10baseT/Full 
	                        100baseT/Half 100baseT/Full 
	                        1000baseT/Full 
	Supports auto-negotiation: Yes
	Advertised link modes:  10baseT/Half 10baseT/Full 
	                        100baseT/Half 100baseT/Full 
	                        1000baseT/Full 
	Advertised auto-negotiation: Yes
	Speed: Unknown!
	Duplex: Unknown! (255)
	Port: Twisted Pair
	PHYAD: 1
	Transceiver: internal
	Auto-negotiation: on
	Supports Wake-on: pumbag
	Wake-on: g
	Current message level: 0x00000001 (1)
	Link detected: no

nm-tool:
- Device: eth0 -----------------------------------------------------------------
  Type:              Wired
  Driver:            e1000e
  State:             unavailable
  Default:           no
  HW Address:        00:15:58:CD:CE:F0

  Capabilities:
    Carrier Detect:  yes

  Wired Properties
    Carrier:         off

/etc/rc.d/init.d/network restart
Bringing up interface eth0:  
Determining IP information for eth0... failed; no link present.  Check cable?
                                                           [FAILED]

the cable is fine, tried other ones as well
the two status lights next to the ethernet are always continuously on, doesnt matter whether a cable is connected or not.


Version-Release number of selected component (if applicable):
kernel 2.6.32.16-150.fc12
Comment 1 Chuck Ebbert 2010-08-07 01:43:26 EDT
Please post output of the command 'lspci -vvvnn' when running the old and new kernels (as separate plain-text attachments, not inline.) You will need to run the commands as root to get all of the information.
Comment 2 Jan Teichmann 2010-08-08 05:37:50 EDT
spontaneous self-healing process: suddenly after some days it's working again. I would say I didn't changed/tried anything which could have fixed it.
Anyhow, thank you very much for your help!

Note You need to log in before you can comment on or make changes to this bug.