Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 621904 - Broken ks cobbler profiles after Org removal
Broken ks cobbler profiles after Org removal
Status: CLOSED DEFERRED
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Other (Show other bugs)
540
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Mráka
Red Hat Satellite QA List
:
Depends On:
Blocks: 462714
  Show dependency treegraph
 
Reported: 2010-08-06 09:11 EDT by Garik Khachikyan
Modified: 2015-01-04 16:57 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-04 09:25:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Garik Khachikyan 2010-08-06 09:11:41 EDT
Description of problem:
There is currently SW not cleans the cobbler profiles after removing the organization.
Due to this, in PXE booting menu the cobbler profiles of that organization (which actually no longer in SW) are still present, and the provisioning fails with "Unable to retrieve the install image"

Version-Release number of selected component (if applicable):
spacewalk-java-1.1.41-1.el5
spacewalk-html-1.1.6-1.el5
spacewalk-oracle-1.1.6-1.el5
spacewalk-schema-1.1.19-1.el5
cobbler-2.0.3.1-3.el5

How reproducible:
always (multi-org, removing the org which had ks profiles prepared)

Steps to Reproduce:
1. sync Fedora 13 content, mount the *.iso (to make ks distribution)
2. make an org, share the Fedora 13 channel (or make the channel visibility to public)
3. prepare ks distribution with a path to the mounted iso directory.
4. create ks profile
5. Delete the org
6. Run cobbler profile list

  
Actual results:
in the list of the profiles there is that ks profile of the org which is already removed.
Due to this PXE booting will list that profile and its selection will brake the provisioning process

Expected results:
cleanup of the broken (irrelevant) ks profiles while removing the org 

Additional info:

Note You need to log in before you can comment on or make changes to this bug.