Bug 621906 - Expose remote API for ServerPluginsBean
Summary: Expose remote API for ServerPluginsBean
Status: CLOSED NEXTRELEASE
Alias: None
Product: RHQ Project
Classification: Other
Component: Core Server (Show other bugs)
(Show other bugs)
Version: 3.0.0
Hardware: All Linux
low
medium vote
Target Milestone: GA
: RHQ 4.12
Assignee: RHQ Project Maintainer
QA Contact: Mike Foley
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-06 13:16 UTC by John Sanda
Modified: 2014-06-18 19:36 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-18 19:36:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 1068816 None None None Never

Description John Sanda 2010-08-06 13:16:50 UTC
Description of problem:
We currently expose a local interface for ServerPluginsBean which provides operations for working with server-side plugins like retrieving them, enabling/disabling them, and invoking operations. It would be really nice to open up some of these operations for use in the remote client and in the CLI.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Jay Shaughnessy 2014-06-18 19:36:03 UTC
This was recently remoted due to Bug 1068816.


Note You need to log in before you can comment on or make changes to this bug.